diff mbox series

[1/3] clk: ti: dra7xx: fix gpu clkctrl parent

Message ID 20200430083640.8621-2-t-kristo@ti.com (mailing list archive)
State New, archived
Headers show
Series clk: ti: dra7xx: clkctrl data fixes | expand

Commit Message

Tero Kristo April 30, 2020, 8:36 a.m. UTC
gpu_cm:* parent clock name is wrong, replace this with correct
gpu-clkctrl:* clock. Otherwise the clock ends up in the orphaned list.

Signed-off-by: Tero Kristo <t-kristo@ti.com>
---
 drivers/clk/ti/clk-7xx.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Stephen Boyd May 14, 2020, 7:55 p.m. UTC | #1
Quoting Tero Kristo (2020-04-30 01:36:38)
> gpu_cm:* parent clock name is wrong, replace this with correct
> gpu-clkctrl:* clock. Otherwise the clock ends up in the orphaned list.
> 
> Signed-off-by: Tero Kristo <t-kristo@ti.com>
> ---

Applied to clk-next
diff mbox series

Patch

diff --git a/drivers/clk/ti/clk-7xx.c b/drivers/clk/ti/clk-7xx.c
index 14b645093107..366cb75378cb 100644
--- a/drivers/clk/ti/clk-7xx.c
+++ b/drivers/clk/ti/clk-7xx.c
@@ -328,7 +328,7 @@  static const struct omap_clkctrl_bit_data dra7_gpu_core_bit_data[] __initconst =
 };
 
 static const struct omap_clkctrl_reg_data dra7_gpu_clkctrl_regs[] __initconst = {
-	{ DRA7_GPU_CLKCTRL, dra7_gpu_core_bit_data, CLKF_SW_SUP, "gpu_cm:clk:0000:24", },
+	{ DRA7_GPU_CLKCTRL, dra7_gpu_core_bit_data, CLKF_SW_SUP, "gpu-clkctrl:0000:24", },
 	{ 0 },
 };