mbox series

[0/7] zfcp: cleanups and small changes for 5.9

Message ID cover.1593780621.git.bblock@linux.ibm.com (mailing list archive)
Headers show
Series zfcp: cleanups and small changes for 5.9 | expand

Message

Benjamin Block July 3, 2020, 1:19 p.m. UTC
Hello Martin, James, Jonathan,

here are some cleanups and small changes for zfcp I'd like to include in
5.9 if possible.

One of the changes touches documentation in `Documentation/scsi/`, so I
put Jonathan on To, hope that was correct. I hope you can still pull
this all in one go to minimize work. IBM did retire some old URLs and
content from our public website, so we have to clean that up in the
documentation so there are not dead links. I changed these in the hopes
we can minimize documentation churn going forward, just to replace URLs.

The other changes are mostly small cleanups for our driver that make at
least parts more sane than they've been.

Most of these have been in our CI for quite a while now - shame on me
for delaying sending them upstream so long -, so I am rather confident
that they don't break anything for us.

As always, feedback and reviews are appreciated :-)

Benjamin Block (2):
  scsi: docs: update outdated link to IBM developerworks
  scsi: docs: remove invalid link and update text for zfcp kernel config

George Spelvin (1):
  zfcp: use prandom_u32_max() for backoff

Julian Wiedmann (4):
  zfcp: fix an outdated comment for zfcp_qdio_send()
  zfcp: clean up zfcp_erp_action_ready()
  zfcp: replace open-coded list move
  zfcp: avoid benign overflow of the Request Queue's free-level

 Documentation/scsi/scsi-parameters.rst |  2 +-
 drivers/s390/scsi/zfcp_ccw.c           |  7 +++----
 drivers/s390/scsi/zfcp_erp.c           |  2 +-
 drivers/s390/scsi/zfcp_fc.c            |  2 +-
 drivers/s390/scsi/zfcp_qdio.c          |  7 +++++--
 drivers/scsi/Kconfig                   | 15 ++++++++++-----
 6 files changed, 21 insertions(+), 14 deletions(-)

Comments

Martin K. Petersen July 8, 2020, 6:06 a.m. UTC | #1
On Fri, 3 Jul 2020 15:19:56 +0200, Benjamin Block wrote:

> here are some cleanups and small changes for zfcp I'd like to include in
> 5.9 if possible.
> 
> One of the changes touches documentation in `Documentation/scsi/`, so I
> put Jonathan on To, hope that was correct. I hope you can still pull
> this all in one go to minimize work. IBM did retire some old URLs and
> content from our public website, so we have to clean that up in the
> documentation so there are not dead links. I changed these in the hopes
> we can minimize documentation churn going forward, just to replace URLs.
> 
> [...]

Applied to 5.9/scsi-queue, thanks!

[1/7] scsi: zfcp: Use prandom_u32_max() for backoff
      https://git.kernel.org/mkp/scsi/c/0cd0e57ec858
[2/7] scsi: zfcp: Fix an outdated comment for zfcp_qdio_send()
      https://git.kernel.org/mkp/scsi/c/459ad085d87b
[3/7] scsi: docs: Update outdated link to IBM developerworks
      https://git.kernel.org/mkp/scsi/c/b9789bfbfe9d
[4/7] scsi: docs: Remove invalid link and update text for zfcp kernel config
      https://git.kernel.org/mkp/scsi/c/c06de6e28c9e
[5/7] scsi: zfcp: Clean up zfcp_erp_action_ready()
      https://git.kernel.org/mkp/scsi/c/b43cdb5ac856
[6/7] scsi: zfcp: Replace open-coded list move
      https://git.kernel.org/mkp/scsi/c/6bcb7c171a0c
[7/7] scsi: zfcp: Avoid benign overflow of the Request Queue's free-level
      https://git.kernel.org/mkp/scsi/c/c3bfffa5ec69
Benjamin Block July 8, 2020, 1:12 p.m. UTC | #2
On Wed, Jul 08, 2020 at 02:06:45AM -0400, Martin K. Petersen wrote:
> On Fri, 3 Jul 2020 15:19:56 +0200, Benjamin Block wrote:
> 
> > here are some cleanups and small changes for zfcp I'd like to include in
> > 5.9 if possible.
> > 
> > One of the changes touches documentation in `Documentation/scsi/`, so I
> > put Jonathan on To, hope that was correct. I hope you can still pull
> > this all in one go to minimize work. IBM did retire some old URLs and
> > content from our public website, so we have to clean that up in the
> > documentation so there are not dead links. I changed these in the hopes
> > we can minimize documentation churn going forward, just to replace URLs.
> > 
> > [...]
> 
> Applied to 5.9/scsi-queue, thanks!
> 
> [1/7] scsi: zfcp: Use prandom_u32_max() for backoff
>       https://git.kernel.org/mkp/scsi/c/0cd0e57ec858
> [2/7] scsi: zfcp: Fix an outdated comment for zfcp_qdio_send()
>       https://git.kernel.org/mkp/scsi/c/459ad085d87b
> [3/7] scsi: docs: Update outdated link to IBM developerworks
>       https://git.kernel.org/mkp/scsi/c/b9789bfbfe9d
> [4/7] scsi: docs: Remove invalid link and update text for zfcp kernel config
>       https://git.kernel.org/mkp/scsi/c/c06de6e28c9e
> [5/7] scsi: zfcp: Clean up zfcp_erp_action_ready()
>       https://git.kernel.org/mkp/scsi/c/b43cdb5ac856
> [6/7] scsi: zfcp: Replace open-coded list move
>       https://git.kernel.org/mkp/scsi/c/6bcb7c171a0c
> [7/7] scsi: zfcp: Avoid benign overflow of the Request Queue's free-level
>       https://git.kernel.org/mkp/scsi/c/c3bfffa5ec69
> 

Thanks Martin!