Message ID | 20200723204244.24457-2-Larry.Finger@lwfinger.net (mailing list archive) |
---|---|
State | Accepted |
Commit | 78a7245d84300cd616dbce26e6fc42a039a62279 |
Delegated to: | Kalle Valo |
Headers | show |
Series | rtlwifi: Change RT_TRACE into rtl_dbg for all drivers | expand |
Larry Finger <Larry.Finger@lwfinger.net> wrote: > The macro name RT_TRACE makes it seem that it is used for tracing, when > is actually used for debugging. Change the name to RT_DEBUG. > > This step creates the new macro while keeping the old RT_TRACE to allow > building. It will be removed at the end of the patch series. > > Signed-off-by: Larry Finger <Larry.Finger@lwfinger.net> 13 patches applied to wireless-drivers-next.git, thanks. 78a7245d8430 rtlwifi: Start changing RT_TRACE into rtl_dbg f108a420e50a rtlwifi: Replace RT_TRACE with rtl_dbg c8159c3ff8db rtlwifi: btcoexist: Replace RT_TRACE with rtl_dbg 57b0b743e402 rtlwifi: rtl8188ee: Rename RT_TRACE to rtl_dbg 5b4e998b8ae7 rtlwifi: rtl8192-common: Rename RT_TRACE to rtl_dbg de0c8a968809 rtlwifi: rtl8192ce: Rename RT_TRACE to rtl_dbg 34d7f007171d rtlwifi: rtl8192cu: Rename RT_TRACE to rtl_dbg 6bf8bc19297b rtlwifi: rtl8192de: Rename RT_TRACE to rtl_dbg e24a2a8795fb rtlwifi: rtl8192ee: Rename RT_TRACE to rtl_dbg fca8218d33f3 rtlwifi: rtl8192se Rename RT_TRACE to rtl_dbg 8f11dad4145c rtlwifi: rtl8723ae Rename RT_TRACE to rtl_dbg e6dd230a4d8e rtlwifi: rtl8723be Rename RT_TRACE to rtl_dbg b58c18c88c20 rtlwifi: rtl8723-common: Rename RT_TRACE to rtl_dbg
diff --git a/drivers/net/wireless/realtek/rtlwifi/debug.h b/drivers/net/wireless/realtek/rtlwifi/debug.h index 69f169d4d4ae..dbfb4d67ca31 100644 --- a/drivers/net/wireless/realtek/rtlwifi/debug.h +++ b/drivers/net/wireless/realtek/rtlwifi/debug.h @@ -160,6 +160,10 @@ void _rtl_dbg_print_data(struct rtl_priv *rtlpriv, u64 comp, int level, const char *titlestring, const void *hexdata, int hexdatalen); +#define rtl_dbg(rtlpriv, comp, level, fmt, ...) \ + _rtl_dbg_trace(rtlpriv, comp, level, \ + fmt, ##__VA_ARGS__) + #define RT_TRACE(rtlpriv, comp, level, fmt, ...) \ _rtl_dbg_trace(rtlpriv, comp, level, \ fmt, ##__VA_ARGS__) @@ -176,6 +180,13 @@ void _rtl_dbg_print_data(struct rtl_priv *rtlpriv, u64 comp, int level, struct rtl_priv; +__printf(4, 5) +static inline void rtl_dbg(struct rtl_priv *rtlpriv, + u64 comp, int level, + const char *fmt, ...) +{ +} + __printf(4, 5) static inline void RT_TRACE(struct rtl_priv *rtlpriv, u64 comp, int level,
The macro name RT_TRACE makes it seem that it is used for tracing, when is actually used for debugging. Change the name to RT_DEBUG. This step creates the new macro while keeping the old RT_TRACE to allow building. It will be removed at the end of the patch series. Signed-off-by: Larry Finger <Larry.Finger@lwfinger.net> --- v2 - This patch only defines rtl_dbg as suggested by Joe Perches --- drivers/net/wireless/realtek/rtlwifi/debug.h | 11 +++++++++++ 1 file changed, 11 insertions(+)