diff mbox series

riscv: fix pfn_to_virt err in do_page_fault().

Message ID 1600327549-3995-1-git-send-email-liush@allwinnertech.com (mailing list archive)
State New, archived
Headers show
Series riscv: fix pfn_to_virt err in do_page_fault(). | expand

Commit Message

liush Sept. 17, 2020, 7:25 a.m. UTC
The argument to pfn_to_virt() should be pfn not the value of CSR_SATP.

Signed-off-by: liush <liush@allwinnertech.com>
---
 arch/riscv/mm/fault.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Anup Patel Sept. 17, 2020, 7:59 a.m. UTC | #1
On Thu, Sep 17, 2020 at 12:56 PM liush <liush@allwinnertech.com> wrote:
>
> The argument to pfn_to_virt() should be pfn not the value of CSR_SATP.
>
> Signed-off-by: liush <liush@allwinnertech.com>
> ---
>  arch/riscv/mm/fault.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/arch/riscv/mm/fault.c b/arch/riscv/mm/fault.c
> index 716d64e..9b4e088 100644
> --- a/arch/riscv/mm/fault.c
> +++ b/arch/riscv/mm/fault.c
> @@ -212,7 +212,7 @@ asmlinkage void do_page_fault(struct pt_regs *regs)
>                  * of a task switch.
>                  */
>                 index = pgd_index(addr);
> -               pgd = (pgd_t *)pfn_to_virt(csr_read(CSR_SATP)) + index;
> +               pgd = (pgd_t *)pfn_to_virt(csr_read(CSR_SATP) & SATP_PPN) + index;
>                 pgd_k = init_mm.pgd + index;
>
>                 if (!pgd_present(*pgd_k))
> --
> 2.7.4
>

Looks good to me.

Reviewed-by: Anup Patel <anup@brainfault.org>

Regards,
Anup
Christoph Hellwig Sept. 17, 2020, 3:25 p.m. UTC | #2
On Thu, Sep 17, 2020 at 03:25:49PM +0800, liush wrote:
> The argument to pfn_to_virt() should be pfn not the value of CSR_SATP.
> 
> Signed-off-by: liush <liush@allwinnertech.com>
> ---
>  arch/riscv/mm/fault.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/arch/riscv/mm/fault.c b/arch/riscv/mm/fault.c
> index 716d64e..9b4e088 100644
> --- a/arch/riscv/mm/fault.c
> +++ b/arch/riscv/mm/fault.c
> @@ -212,7 +212,7 @@ asmlinkage void do_page_fault(struct pt_regs *regs)
>  		 * of a task switch.
>  		 */
>  		index = pgd_index(addr);
> -		pgd = (pgd_t *)pfn_to_virt(csr_read(CSR_SATP)) + index;
> +		pgd = (pgd_t *)pfn_to_virt(csr_read(CSR_SATP) & SATP_PPN) + index;

This adds a crazy long line.  One nice way to clean this up would be to
add a local pfn variable, as it would also make the code more readable.
liush Sept. 18, 2020, 7:43 a.m. UTC | #3
Hi Christoph,
> On Thu, Sep 17, 2020 at 03:25:49PM +0800, liush wrote:
> > The argument to pfn_to_virt() should be pfn not the value of CSR_SATP.
> > 
> > Signed-off-by: liush <liush@allwinnertech.com>
> > ---
> >  arch/riscv/mm/fault.c | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/arch/riscv/mm/fault.c b/arch/riscv/mm/fault.c
> > index 716d64e..9b4e088 100644
> > --- a/arch/riscv/mm/fault.c
> > +++ b/arch/riscv/mm/fault.c
> > @@ -212,7 +212,7 @@ asmlinkage void do_page_fault(struct pt_regs *regs)
> >     * of a task switch.
> >     */
> >    index = pgd_index(addr);
> > -  pgd = (pgd_t *)pfn_to_virt(csr_read(CSR_SATP)) + index;
> > +  pgd = (pgd_t *)pfn_to_virt(csr_read(CSR_SATP) & SATP_PPN) + index;

> This adds a crazy long line.  One nice way to clean this up would be to
> add a local pfn variable, as it would also make the code more readable.

Thanks, i'll modify it in next revision
fuyao Sept. 28, 2020, 9:31 a.m. UTC | #4
On Fri, Sep 18, 2020 at 03:43:39PM +0800, 刘邵华BTD wrote:
> Hi Christoph,
> > On Thu, Sep 17, 2020 at 03:25:49PM +0800, liush wrote:
> > > The argument to pfn_to_virt() should be pfn not the value of CSR_SATP.
> > > 
> > > Signed-off-by: liush <liush@allwinnertech.com>
> > > ---
> > >  arch/riscv/mm/fault.c | 2 +-
> > >  1 file changed, 1 insertion(+), 1 deletion(-)
> > > 
> > > diff --git a/arch/riscv/mm/fault.c b/arch/riscv/mm/fault.c
> > > index 716d64e..9b4e088 100644
> > > --- a/arch/riscv/mm/fault.c
> > > +++ b/arch/riscv/mm/fault.c
> > > @@ -212,7 +212,7 @@ asmlinkage void do_page_fault(struct pt_regs *regs)
> > >     * of a task switch.
> > >     */
> > >    index = pgd_index(addr);
> > > -  pgd = (pgd_t *)pfn_to_virt(csr_read(CSR_SATP)) + index;
> > > +  pgd = (pgd_t *)pfn_to_virt(csr_read(CSR_SATP) & SATP_PPN) + index;
> 
> > This adds a crazy long line.  One nice way to clean this up would be to
> > add a local pfn variable, as it would also make the code more readable.
> 
> Thanks, i'll modify it in next revision

Tested-by: fuayo@allwinnertech.com
diff mbox series

Patch

diff --git a/arch/riscv/mm/fault.c b/arch/riscv/mm/fault.c
index 716d64e..9b4e088 100644
--- a/arch/riscv/mm/fault.c
+++ b/arch/riscv/mm/fault.c
@@ -212,7 +212,7 @@  asmlinkage void do_page_fault(struct pt_regs *regs)
 		 * of a task switch.
 		 */
 		index = pgd_index(addr);
-		pgd = (pgd_t *)pfn_to_virt(csr_read(CSR_SATP)) + index;
+		pgd = (pgd_t *)pfn_to_virt(csr_read(CSR_SATP) & SATP_PPN) + index;
 		pgd_k = init_mm.pgd + index;
 
 		if (!pgd_present(*pgd_k))