diff mbox series

[v2,1/2] drivers: gpio: put virtual gpio device into their own submenu

Message ID 20201203191135.21576-1-info@metux.net (mailing list archive)
State New, archived
Headers show
Series [v2,1/2] drivers: gpio: put virtual gpio device into their own submenu | expand

Commit Message

Enrico Weigelt, metux IT consult Dec. 3, 2020, 7:11 p.m. UTC
Since we already have a few virtual gpio devices, and more to come,
this category deserves its own submenu.

Signed-off-by: Enrico Weigelt, metux IT consult <info@metux.net>
---
 drivers/gpio/Kconfig | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Andy Shevchenko Dec. 7, 2020, 9:55 a.m. UTC | #1
On Thu, Dec 3, 2020 at 9:22 PM Enrico Weigelt, metux IT consult
<info@metux.net> wrote:
>
> Since we already have a few virtual gpio devices, and more to come,

gpio -> GPIO

> this category deserves its own submenu.
Bartosz Golaszewski Dec. 7, 2020, 10:31 a.m. UTC | #2
On Thu, Dec 3, 2020 at 8:11 PM Enrico Weigelt, metux IT consult
<info@metux.net> wrote:
>
> Since we already have a few virtual gpio devices, and more to come,
> this category deserves its own submenu.
>
> Signed-off-by: Enrico Weigelt, metux IT consult <info@metux.net>
> ---
>  drivers/gpio/Kconfig | 4 ++++
>  1 file changed, 4 insertions(+)
>
> diff --git a/drivers/gpio/Kconfig b/drivers/gpio/Kconfig
> index 5d4de5cd6759..01619eb58396 100644
> --- a/drivers/gpio/Kconfig
> +++ b/drivers/gpio/Kconfig
> @@ -1590,6 +1590,8 @@ config GPIO_VIPERBOARD
>
>  endmenu
>
> +menu "Virtual GPIO devices"
> +
>  config GPIO_AGGREGATOR
>         tristate "GPIO Aggregator"
>         help
> @@ -1613,4 +1615,6 @@ config GPIO_MOCKUP
>           tools/testing/selftests/gpio/gpio-mockup.sh. Reference the usage in
>           it.
>
> +endmenu
> +
>  endif
> --
> 2.11.0
>

I'd call this section "Virtual GPIO drivers" because the code contains
drivers not devices.

Bartosz
Enrico Weigelt, metux IT consult Dec. 7, 2020, 11:22 a.m. UTC | #3
On 07.12.20 11:31, Bartosz Golaszewski wrote:

> I'd call this section "Virtual GPIO drivers" because the code contains
> drivers not devices.

fixed in v2.


--mtx
diff mbox series

Patch

diff --git a/drivers/gpio/Kconfig b/drivers/gpio/Kconfig
index 5d4de5cd6759..01619eb58396 100644
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
@@ -1590,6 +1590,8 @@  config GPIO_VIPERBOARD
 
 endmenu
 
+menu "Virtual GPIO devices"
+
 config GPIO_AGGREGATOR
 	tristate "GPIO Aggregator"
 	help
@@ -1613,4 +1615,6 @@  config GPIO_MOCKUP
 	  tools/testing/selftests/gpio/gpio-mockup.sh. Reference the usage in
 	  it.
 
+endmenu
+
 endif