mbox series

[v4,0/5] ceph: new mount device syntax

Message ID 20210714100554.85978-1-vshankar@redhat.com (mailing list archive)
Headers show
Series ceph: new mount device syntax | expand

Message

Venky Shankar July 14, 2021, 10:05 a.m. UTC
v4:
  - fix delimiter check in ceph_parse_ips()
  - use __func__ in ceph_parse_ips() instead of hardcoded function name
  - KERN_NOTICE that mon_addr is recorded but not reconnected

Venky Shankar (5):
  ceph: generalize addr/ip parsing based on delimiter
  ceph: rename parse_fsid() to ceph_parse_fsid() and export
  ceph: new device mount syntax
  ceph: record updated mon_addr on remount
  doc: document new CephFS mount device syntax

 Documentation/filesystems/ceph.rst |  25 ++++-
 drivers/block/rbd.c                |   3 +-
 fs/ceph/super.c                    | 151 +++++++++++++++++++++++++++--
 fs/ceph/super.h                    |   3 +
 include/linux/ceph/libceph.h       |   5 +-
 include/linux/ceph/messenger.h     |   2 +-
 net/ceph/ceph_common.c             |  17 ++--
 net/ceph/messenger.c               |   8 +-
 8 files changed, 186 insertions(+), 28 deletions(-)

Comments

Jeff Layton July 14, 2021, 3:33 p.m. UTC | #1
On Wed, 2021-07-14 at 15:35 +0530, Venky Shankar wrote:
> v4:
>   - fix delimiter check in ceph_parse_ips()
>   - use __func__ in ceph_parse_ips() instead of hardcoded function name
>   - KERN_NOTICE that mon_addr is recorded but not reconnected
> 
> Venky Shankar (5):
>   ceph: generalize addr/ip parsing based on delimiter
>   ceph: rename parse_fsid() to ceph_parse_fsid() and export
>   ceph: new device mount syntax
>   ceph: record updated mon_addr on remount
>   doc: document new CephFS mount device syntax
> 
>  Documentation/filesystems/ceph.rst |  25 ++++-
>  drivers/block/rbd.c                |   3 +-
>  fs/ceph/super.c                    | 151 +++++++++++++++++++++++++++--
>  fs/ceph/super.h                    |   3 +
>  include/linux/ceph/libceph.h       |   5 +-
>  include/linux/ceph/messenger.h     |   2 +-
>  net/ceph/ceph_common.c             |  17 ++--
>  net/ceph/messenger.c               |   8 +-
>  8 files changed, 186 insertions(+), 28 deletions(-)
> 

This looks good, Venky. Nice work!

I'm doing a bit of testing with this now, and will plan to merge it into
the testing branch later today.
Jeff Layton July 16, 2021, 6:47 p.m. UTC | #2
On Wed, 2021-07-14 at 15:35 +0530, Venky Shankar wrote:
> v4:
>   - fix delimiter check in ceph_parse_ips()
>   - use __func__ in ceph_parse_ips() instead of hardcoded function name
>   - KERN_NOTICE that mon_addr is recorded but not reconnected
> 
> Venky Shankar (5):
>   ceph: generalize addr/ip parsing based on delimiter
>   ceph: rename parse_fsid() to ceph_parse_fsid() and export
>   ceph: new device mount syntax
>   ceph: record updated mon_addr on remount
>   doc: document new CephFS mount device syntax
> 
>  Documentation/filesystems/ceph.rst |  25 ++++-
>  drivers/block/rbd.c                |   3 +-
>  fs/ceph/super.c                    | 151 +++++++++++++++++++++++++++--
>  fs/ceph/super.h                    |   3 +
>  include/linux/ceph/libceph.h       |   5 +-
>  include/linux/ceph/messenger.h     |   2 +-
>  net/ceph/ceph_common.c             |  17 ++--
>  net/ceph/messenger.c               |   8 +-
>  8 files changed, 186 insertions(+), 28 deletions(-)
> 

I've gone ahead and merged these into the testing branch, though I have
not had time to personally do any testing with the new mount helper or
new syntax. It does seem to behave fine with the old mount helper and
syntax.

Venky, I did make a couple of minor changes to this patch:

    ceph: record updated mon_addr on remount

Please take a look when you have time and make sure they're OK.

Thanks,
Venky Shankar July 19, 2021, 7:03 a.m. UTC | #3
On Sat, Jul 17, 2021 at 12:17 AM Jeff Layton <jlayton@redhat.com> wrote:
>
> On Wed, 2021-07-14 at 15:35 +0530, Venky Shankar wrote:
> > v4:
> >   - fix delimiter check in ceph_parse_ips()
> >   - use __func__ in ceph_parse_ips() instead of hardcoded function name
> >   - KERN_NOTICE that mon_addr is recorded but not reconnected
> >
> > Venky Shankar (5):
> >   ceph: generalize addr/ip parsing based on delimiter
> >   ceph: rename parse_fsid() to ceph_parse_fsid() and export
> >   ceph: new device mount syntax
> >   ceph: record updated mon_addr on remount
> >   doc: document new CephFS mount device syntax
> >
> >  Documentation/filesystems/ceph.rst |  25 ++++-
> >  drivers/block/rbd.c                |   3 +-
> >  fs/ceph/super.c                    | 151 +++++++++++++++++++++++++++--
> >  fs/ceph/super.h                    |   3 +
> >  include/linux/ceph/libceph.h       |   5 +-
> >  include/linux/ceph/messenger.h     |   2 +-
> >  net/ceph/ceph_common.c             |  17 ++--
> >  net/ceph/messenger.c               |   8 +-
> >  8 files changed, 186 insertions(+), 28 deletions(-)
> >
>
> I've gone ahead and merged these into the testing branch, though I have
> not had time to personally do any testing with the new mount helper or
> new syntax. It does seem to behave fine with the old mount helper and
> syntax.
>
> Venky, I did make a couple of minor changes to this patch:
>
>     ceph: record updated mon_addr on remount
>
> Please take a look when you have time and make sure they're OK.

Looks good, Thanks.

>
> Thanks,
> --
> Jeff Layton <jlayton@redhat.com>
>