mbox series

[for-next,0/9] RDMA/hns: Cleanup for clearing static warnings

Message ID 20211119140208.40416-1-liangwenpeng@huawei.com (mailing list archive)
Headers show
Series RDMA/hns: Cleanup for clearing static warnings | expand

Message

Wenpeng Liang Nov. 19, 2021, 2:01 p.m. UTC
Most static warnings are detected by tools, mainly about:

(1) #1~2: About printing format.
(2) #3  : About code comments.
(3) #4~6: About variable definition and initialization.
(4) #7~9: Other miscellaneous.

Haoyue Xu (1):
  RDMA/hns: Initialize variable in the right place

Xinhao Liu (7):
  RDMA/hns: Correct the hex print format
  RDMA/hns: Correct the print format to be consistent with the variable
    type
  RDMA/hns: Replace tab with space in the right-side comments
  RDMA/hns: Correct the type of variables participating in the shift
    operation
  RDMA/hns: Correctly initialize the members of Array[][]
  RDMA/hns: Add void conversion for function whose return value is not
    used
  RDMA/hns: Remove magic number

Yixing Liu (1):
  RDMA/hns: Remove macros that are no longer used

 drivers/infiniband/hw/hns/hns_roce_cmd.c    | 10 +++---
 drivers/infiniband/hw/hns/hns_roce_device.h | 40 ++++++++++-----------
 drivers/infiniband/hw/hns/hns_roce_hw_v2.c  | 23 ++++++------
 drivers/infiniband/hw/hns/hns_roce_hw_v2.h  | 18 +---------
 drivers/infiniband/hw/hns/hns_roce_mr.c     | 10 +++---
 drivers/infiniband/hw/hns/hns_roce_qp.c     |  2 +-
 6 files changed, 45 insertions(+), 58 deletions(-)

--
2.33.0

Comments

Jason Gunthorpe Nov. 19, 2021, 6:18 p.m. UTC | #1
On Fri, Nov 19, 2021 at 10:01:59PM +0800, Wenpeng Liang wrote:

>   RDMA/hns: Correct the hex print format
>   RDMA/hns: Correct the print format to be consistent with the variable
>     type
>   RDMA/hns: Replace tab with space in the right-side comments
>   RDMA/hns: Correct the type of variables participating in the shift
>     operation
>   RDMA/hns: Correctly initialize the members of Array[][]
>   RDMA/hns: Remove magic number

I took these patches to for-next

>   RDMA/hns: Initialize variable in the right place
>   RDMA/hns: Add void conversion for function whose return value is not
>     used

Not keen on these

Thanks,
Jason