mbox series

[for-next,00/12] RDMA/hns: Cleanups for kernel-6.1

Message ID 20220922123315.3732205-1-xuhaoyue1@hisilicon.com (mailing list archive)
Headers show
Series RDMA/hns: Cleanups for kernel-6.1 | expand

Message

Haoyue Xu Sept. 22, 2022, 12:33 p.m. UTC
This series includes:
(1) #1: About the spelling mistakes.
(2) #2: About the unnecessary braces.
(3) #3: About the unnecessary brackets.
(4) #4 #5 #6 #7 #8 #9: About the redundant variables.
(5) #10 #11: About Repacing constant variables by macros.
(6) #12: About Unified log style.

Chengchang Tang (1):
  RDMA/hns: Remove redundant 'phy_addr' in hns_roce_hem_list_find_mtt()

Guofeng Yue (4):
  RDMA/hns: Cleanup for a spelling error of Asynchronous
  RDMA/hns: Remove unnecessary braces for single statement blocks
  RDMA/hns: Remove unnecessary brackets when getting point
  RDMA/hns: Unified Log Printing Style

Luoyouming (1):
  RDMA/hns: Repacing 'dseg_len' by macros in fill_ext_sge_inl_data()

Yangyang Li (2):
  RDMA/hns: Remove redundant 'num_mtt_segs' and 'max_extend_sg'
  RDMA/hns: Remove redundant 'max_srq_desc_sz' in caps

Yixing Liu (2):
  RDMA/hns: Remove redundant 'attr_mask' in modify_qp_init_to_init()
  RDMA/hns: Replacing magic number with macros in apply_func_caps()

Yunsheng Lin (2):
  RDMA/hns: Remove redundant 'bt_level' for hem_list_alloc_item()
  RDMA/hns: Remove redundant 'use_lowmem' argument from
    hns_roce_init_hem_table()

 drivers/infiniband/hw/hns/hns_roce_cq.c     |  6 +-
 drivers/infiniband/hw/hns/hns_roce_device.h |  7 +-
 drivers/infiniband/hw/hns/hns_roce_hem.c    | 33 +++-----
 drivers/infiniband/hw/hns/hns_roce_hem.h    |  5 +-
 drivers/infiniband/hw/hns/hns_roce_hw_v2.c  | 85 ++++++++++-----------
 drivers/infiniband/hw/hns/hns_roce_hw_v2.h  |  8 +-
 drivers/infiniband/hw/hns/hns_roce_main.c   | 53 +++++++------
 drivers/infiniband/hw/hns/hns_roce_mr.c     |  6 +-
 drivers/infiniband/hw/hns/hns_roce_qp.c     | 16 ++--
 9 files changed, 98 insertions(+), 121 deletions(-)

Comments

Jason Gunthorpe Sept. 26, 2022, 6:16 p.m. UTC | #1
On Thu, Sep 22, 2022 at 08:33:03PM +0800, Haoyue Xu wrote:
> This series includes:
> (1) #1: About the spelling mistakes.
> (2) #2: About the unnecessary braces.
> (3) #3: About the unnecessary brackets.
> (4) #4 #5 #6 #7 #8 #9: About the redundant variables.
> (5) #10 #11: About Repacing constant variables by macros.
> (6) #12: About Unified log style.
> 
> Chengchang Tang (1):
>   RDMA/hns: Remove redundant 'phy_addr' in hns_roce_hem_list_find_mtt()
> 
> Guofeng Yue (4):
>   RDMA/hns: Cleanup for a spelling error of Asynchronous
>   RDMA/hns: Remove unnecessary braces for single statement blocks
>   RDMA/hns: Remove unnecessary brackets when getting point
>   RDMA/hns: Unified Log Printing Style
> 
> Luoyouming (1):
>   RDMA/hns: Repacing 'dseg_len' by macros in fill_ext_sge_inl_data()
> 
> Yangyang Li (2):
>   RDMA/hns: Remove redundant 'num_mtt_segs' and 'max_extend_sg'
>   RDMA/hns: Remove redundant 'max_srq_desc_sz' in caps
> 
> Yixing Liu (2):
>   RDMA/hns: Remove redundant 'attr_mask' in modify_qp_init_to_init()
>   RDMA/hns: Replacing magic number with macros in apply_func_caps()
> 
> Yunsheng Lin (2):
>   RDMA/hns: Remove redundant 'bt_level' for hem_list_alloc_item()
>   RDMA/hns: Remove redundant 'use_lowmem' argument from
>     hns_roce_init_hem_table()

Applied to for-next, thanks

Jason