Message ID | 20230204233001.1511643-5-martin.blumenstingl@googlemail.com (mailing list archive) |
---|---|
State | Accepted |
Commit | 24d54855ff36c7c6256cb48b735a927090142a51 |
Delegated to: | Kalle Valo |
Headers | show |
Series | rtw88: four small code-cleanups and refactorings | expand |
On Sun, Feb 05, 2023 at 12:30:01AM +0100, Martin Blumenstingl wrote: > Replace the magic numbers for the intf_mask with their existing > RTW_PWR_INTF_PCI_MSK and RTW_PWR_INTF_USB_MSK macros to make the code > easier to understand. > > Acked-by: Ping-Ke Shih <pkshih@realtek.com> > Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com> Reviewed-by: Simon Horman <simon.horman@corigine.com>
diff --git a/drivers/net/wireless/realtek/rtw88/mac.c b/drivers/net/wireless/realtek/rtw88/mac.c index 98777f294945..4e5c194aac29 100644 --- a/drivers/net/wireless/realtek/rtw88/mac.c +++ b/drivers/net/wireless/realtek/rtw88/mac.c @@ -217,10 +217,10 @@ static int rtw_pwr_seq_parser(struct rtw_dev *rtwdev, cut_mask = cut_version_to_mask(cut); switch (rtw_hci_type(rtwdev)) { case RTW_HCI_TYPE_PCIE: - intf_mask = BIT(2); + intf_mask = RTW_PWR_INTF_PCI_MSK; break; case RTW_HCI_TYPE_USB: - intf_mask = BIT(1); + intf_mask = RTW_PWR_INTF_USB_MSK; break; default: return -EINVAL;