Message ID | 20230420051946.7463-4-yury.norov@gmail.com (mailing list archive) |
---|---|
State | Superseded |
Headers | show |
Series | sched/topology: add for_each_numa_cpu() macro | expand |
On 19/04/23 22:19, Yury Norov wrote: > +/** > + * for_each_numa_cpu - iterate over cpus in increasing order taking into account > + * NUMA distances from a given node. > + * @cpu: the (optionally unsigned) integer iterator > + * @hop: the iterator variable, must be initialized to a desired minimal hop. > + * @node: the NUMA node to start the search from. > + * @mask: the cpumask pointer > + * > + * Requires rcu_lock to be held. > + */ > +#define for_each_numa_cpu(cpu, hop, node, mask) \ > + for ((cpu) = 0, (hop) = 0; \ > + (cpu) = sched_numa_find_next_cpu((mask), (cpu), (node), &(hop)),\ > + (cpu) < nr_cpu_ids; \ > + (cpu)++) > + I think we can keep sched_numa_find_next_cpu() as-is, but could we make that macro use cpu_possible_mask by default? We can always add a variant if/when we need to feed in a different mask. > #endif /* _LINUX_TOPOLOGY_H */ > -- > 2.34.1
On Tue, Apr 25, 2023 at 10:54:48AM +0100, Valentin Schneider wrote: > On 19/04/23 22:19, Yury Norov wrote: > > +/** > > + * for_each_numa_cpu - iterate over cpus in increasing order taking into account > > + * NUMA distances from a given node. > > + * @cpu: the (optionally unsigned) integer iterator > > + * @hop: the iterator variable, must be initialized to a desired minimal hop. > > + * @node: the NUMA node to start the search from. > > + * @mask: the cpumask pointer > > + * > > + * Requires rcu_lock to be held. > > + */ > > +#define for_each_numa_cpu(cpu, hop, node, mask) \ > > + for ((cpu) = 0, (hop) = 0; \ > > + (cpu) = sched_numa_find_next_cpu((mask), (cpu), (node), &(hop)),\ > > + (cpu) < nr_cpu_ids; \ > > + (cpu)++) > > + > > I think we can keep sched_numa_find_next_cpu() as-is, but could we make > that macro use cpu_possible_mask by default? We can always add a variant > if/when we need to feed in a different mask. As mentioned in discussion to the driver's patch, all that numa things imply only online CPUs, so cpu_possible_mask may mislead to some extent. Anyways, can you elaborate what you exactly want? Like this? #define for_each_numa_online_cpu(cpu, hop, node) \ for_each_numa_cpu(cpu, hop, node, cpu_online_mask)
On 25/04/23 22:32, Yury Norov wrote: > On Tue, Apr 25, 2023 at 10:54:48AM +0100, Valentin Schneider wrote: >> On 19/04/23 22:19, Yury Norov wrote: >> > +/** >> > + * for_each_numa_cpu - iterate over cpus in increasing order taking into account >> > + * NUMA distances from a given node. >> > + * @cpu: the (optionally unsigned) integer iterator >> > + * @hop: the iterator variable, must be initialized to a desired minimal hop. >> > + * @node: the NUMA node to start the search from. >> > + * @mask: the cpumask pointer >> > + * >> > + * Requires rcu_lock to be held. >> > + */ >> > +#define for_each_numa_cpu(cpu, hop, node, mask) \ >> > + for ((cpu) = 0, (hop) = 0; \ >> > + (cpu) = sched_numa_find_next_cpu((mask), (cpu), (node), &(hop)),\ >> > + (cpu) < nr_cpu_ids; \ >> > + (cpu)++) >> > + >> >> I think we can keep sched_numa_find_next_cpu() as-is, but could we make >> that macro use cpu_possible_mask by default? We can always add a variant >> if/when we need to feed in a different mask. > > As mentioned in discussion to the driver's patch, all that numa things > imply only online CPUs, so cpu_possible_mask may mislead to some extent. > > Anyways, can you elaborate what you exactly want? Like this? > > #define for_each_numa_online_cpu(cpu, hop, node) \ > for_each_numa_cpu(cpu, hop, node, cpu_online_mask) Yeah, something like that. Like you said, the NUMA cpumasks built by the scheduler reflect the online topology, so s/possible/online/ shouldn't change much here.
diff --git a/include/linux/topology.h b/include/linux/topology.h index 13209095d6e2..01fb3a55d7ce 100644 --- a/include/linux/topology.h +++ b/include/linux/topology.h @@ -286,4 +286,20 @@ sched_numa_hop_mask(unsigned int node, unsigned int hops) !IS_ERR_OR_NULL(mask); \ __hops++) +/** + * for_each_numa_cpu - iterate over cpus in increasing order taking into account + * NUMA distances from a given node. + * @cpu: the (optionally unsigned) integer iterator + * @hop: the iterator variable, must be initialized to a desired minimal hop. + * @node: the NUMA node to start the search from. + * @mask: the cpumask pointer + * + * Requires rcu_lock to be held. + */ +#define for_each_numa_cpu(cpu, hop, node, mask) \ + for ((cpu) = 0, (hop) = 0; \ + (cpu) = sched_numa_find_next_cpu((mask), (cpu), (node), &(hop)),\ + (cpu) < nr_cpu_ids; \ + (cpu)++) + #endif /* _LINUX_TOPOLOGY_H */
for_each_cpu() is widely used in the kernel, and it's beneficial to create a NUMA-aware version of the macro. Recently added for_each_numa_hop_mask() works, but switching existing codebase to using it is not an easy process. New for_each_numa_cpu() is designed to be similar to the for_each_cpu(). It allows to convert existing code to NUMA-aware as simple as adding a hop iterator variable and passing it inside new macro. for_each_numa_cpu() takes care of the rest. At the moment, we have 2 users of NUMA-aware enumerators. One is Melanox's in-tree driver, and another is Intel's in-review driver: https://lore.kernel.org/lkml/20230216145455.661709-1-pawel.chmielewski@intel.com/ Both real-life examples follow the same pattern: for_each_numa_hop_mask(cpus, prev, node) { for_each_cpu_andnot(cpu, cpus, prev) { if (cnt++ == max_num) goto out; do_something(cpu); } prev = cpus; } With the new macro, it would look like this: for_each_numa_cpu(cpu, hop, node, cpu_possible_mask) { if (cnt++ == max_num) break; do_something(cpu); } Straight conversion of existing for_each_cpu() codebase to NUMA-aware version with for_each_numa_hop_mask() is difficult because it doesn't take a user-provided cpu mask, and eventually ends up with open-coded double loop. With for_each_numa_cpu() it shouldn't be a brainteaser. Consider the NUMA-ignorant example: cpumask_t cpus = get_mask(); int cnt = 0, cpu; for_each_cpu(cpu, cpus) { if (cnt++ == max_num) break; do_something(cpu); } Converting it to NUMA-aware version would be as simple as: cpumask_t cpus = get_mask(); int node = get_node(); int cnt = 0, hop, cpu; for_each_numa_cpu(cpu, hop, node, cpus) { if (cnt++ == max_num) break; do_something(cpu); } The latter looks more verbose and avoids from open-coding that annoying double loop. Another advantage is that it works with a 'hop' parameter with the clear meaning of NUMA distance, and doesn't make people not familiar to enumerator internals bothering with current and previous masks machinery. Signed-off-by: Yury Norov <yury.norov@gmail.com> --- include/linux/topology.h | 16 ++++++++++++++++ 1 file changed, 16 insertions(+)