Message ID | 20240710190426.709964-2-thorsten.blum@toblux.com (mailing list archive) |
---|---|
State | Superseded |
Delegated to: | Ping-Ke Shih |
Headers | show |
Series | wifi: rtw89: chan: Use swap() to improve rtw89_swap_sub_entity() | expand |
Thorsten Blum <thorsten.blum@toblux.com> wrote: > Use the swap() macro to simplify the rtw89_swap_sub_entity() function > and improve its readability. Remove the local variable tmp. > > Fixes the following Coccinelle/coccicheck warning reported by > swap.cocci: > > WARNING opportunity for swap() > > Compile-tested only. > > Signed-off-by: Thorsten Blum <thorsten.blum@toblux.com> The same patch [1] has been applied. [1] https://lore.kernel.org/all/20240529020244.129027-1-jiapeng.chong@linux.alibaba.com/
diff --git a/drivers/net/wireless/realtek/rtw89/chan.c b/drivers/net/wireless/realtek/rtw89/chan.c index 051a3cad6101..3b1997223cc5 100644 --- a/drivers/net/wireless/realtek/rtw89/chan.c +++ b/drivers/net/wireless/realtek/rtw89/chan.c @@ -2322,7 +2322,6 @@ static void rtw89_swap_sub_entity(struct rtw89_dev *rtwdev, enum rtw89_sub_entity_idx idx2) { struct rtw89_hal *hal = &rtwdev->hal; - struct rtw89_sub_entity tmp; struct rtw89_vif *rtwvif; u8 cur; @@ -2332,9 +2331,7 @@ static void rtw89_swap_sub_entity(struct rtw89_dev *rtwdev, hal->sub[idx1].cfg->idx = idx2; hal->sub[idx2].cfg->idx = idx1; - tmp = hal->sub[idx1]; - hal->sub[idx1] = hal->sub[idx2]; - hal->sub[idx2] = tmp; + swap(hal->sub[idx1], hal->sub[idx2]); rtw89_for_each_rtwvif(rtwdev, rtwvif) { if (!rtwvif->chanctx_assigned)
Use the swap() macro to simplify the rtw89_swap_sub_entity() function and improve its readability. Remove the local variable tmp. Fixes the following Coccinelle/coccicheck warning reported by swap.cocci: WARNING opportunity for swap() Compile-tested only. Signed-off-by: Thorsten Blum <thorsten.blum@toblux.com> --- drivers/net/wireless/realtek/rtw89/chan.c | 5 +---- 1 file changed, 1 insertion(+), 4 deletions(-)