redhat: BuildRequires python3
diff mbox series

Message ID 20190916013345.8489-1-honli@redhat.com
State Accepted
Delegated to: Leon Romanovsky
Headers show
Series
  • redhat: BuildRequires python3
Related show

Commit Message

Honggang LI Sept. 16, 2019, 1:33 a.m. UTC
From: Honggang Li <honli@redhat.com>

python2 is obsoleted by python3 in RHEL8 and Fedora-30.

Signed-off-by: Honggang Li <honli@redhat.com>
---
 redhat/rdma-core.spec | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Leon Romanovsky Sept. 24, 2019, 8:12 a.m. UTC | #1
On Mon, Sep 16, 2019 at 09:33:45AM +0800, Honggang LI wrote:
> From: Honggang Li <honli@redhat.com>
>
> python2 is obsoleted by python3 in RHEL8 and Fedora-30.
>
> Signed-off-by: Honggang Li <honli@redhat.com>
> ---
>  redhat/rdma-core.spec | 4 ++++
>  1 file changed, 4 insertions(+)
>

Queued, https://github.com/linux-rdma/rdma-core/pull/585
Thanks

Patch
diff mbox series

diff --git a/redhat/rdma-core.spec b/redhat/rdma-core.spec
index f07919cc..731a4e10 100644
--- a/redhat/rdma-core.spec
+++ b/redhat/rdma-core.spec
@@ -29,8 +29,12 @@  BuildRequires: systemd-devel
 BuildRequires: python3-devel
 BuildRequires: python3-Cython
 %else
+%if 0%{?rhel} == 8 || 0%{?fedora} >= 30
+BuildRequires: python3
+%else
 BuildRequires: python
 %endif
+%endif
 %if 0%{?fedora} >= 21
 BuildRequires: perl-generators
 %endif