Message ID | 20200805174921.16000-3-shouryashukla.oo@gmail.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | t7401: modernize, cleanup and warn | expand |
On Wed, Aug 05, 2020 at 11:19:19PM +0530, Shourya Shukla wrote: > Change the test_i18ncmp syntax from 'test_i18ncmp actual expected' to > 'test_i18ncmp expected actual' to align it with the convention followed > by other tests in the test script. > > Mentored-by: Christian Couder <chriscool@tuxfamily.org> > Mentored-by: Kaartic Sivaraam <kaartic.sivaraam@gmail.com> > Signed-off-by: Shourya Shukla <shouryashukla.oo@gmail.com> > --- > t/t7401-submodule-summary.sh | 8 ++++---- > 1 file changed, 4 insertions(+), 4 deletions(-) > > diff --git a/t/t7401-submodule-summary.sh b/t/t7401-submodule-summary.sh > index 4439fb7c17..18fefdb0ba 100755 > --- a/t/t7401-submodule-summary.sh > +++ b/t/t7401-submodule-summary.sh > @@ -183,7 +183,7 @@ test_expect_success 'typechanged submodule(submodule->blob), --cached' " > < Add foo5 > > EOF > - test_i18ncmp actual expected > + test_i18ncmp expected actual > " > > test_expect_success 'typechanged submodule(submodule->blob), --files' " > @@ -193,7 +193,7 @@ test_expect_success 'typechanged submodule(submodule->blob), --files' " > > Add foo5 > > EOF > - test_i18ncmp actual expected > + test_i18ncmp expected actual > " > > rm -rf sm1 && > @@ -204,7 +204,7 @@ test_expect_success 'typechanged submodule(submodule->blob)' " > * sm1 $head4(submodule)->$head5(blob): > > EOF > - test_i18ncmp actual expected > + test_i18ncmp expected actual > " > > rm -f sm1 && > @@ -217,7 +217,7 @@ test_expect_success 'nonexistent commit' " > Warn: sm1 doesn't contain commit $head4_full > > EOF > - test_i18ncmp actual expected > + test_i18ncmp expected actual > " > > commit_file > -- > 2.27.0 This all looks good, and matches a long-standing convention of having the expected value as the first argument and the comparison value as the latter argument. There's one spot you missed, which could be addressed by folding in this diff on top: --- >8 --- Subject: [PATCH] fixup! t7401: change test_i18ncmp syntax for clarity Signed-off-by: Taylor Blau <me@ttaylorr.com> --- t/t7401-submodule-summary.sh | 10 ++++++---- 1 file changed, 6 insertions(+), 4 deletions(-) diff --git a/t/t7401-submodule-summary.sh b/t/t7401-submodule-summary.sh index 18fefdb0ba..bd8fc8511a 100755 --- a/t/t7401-submodule-summary.sh +++ b/t/t7401-submodule-summary.sh @@ -285,12 +285,14 @@ EOF test_expect_success '--for-status' " git submodule summary --for-status HEAD^ >actual && - test_i18ncmp actual - <<EOF -* sm1 $head6...0000000: + cat >expected <<-\EOF && + * sm1 $head6...0000000: -* sm2 0000000...$head7 (2): - > Add foo9 + * sm2 0000000...$head7 (2): + > Add foo9 + EOF + test_i18ncmp expected actual EOF " -- 2.28.0.rc1.13.ge78abce653
Shourya Shukla <shouryashukla.oo@gmail.com> writes: > Change the test_i18ncmp syntax from 'test_i18ncmp actual expected' to > 'test_i18ncmp expected actual' to align it with the convention followed > by other tests in the test script. Yeah, this is a good thing to do, as a failing test_cmp gives a diff between the first file to the second file, i.e. a patch that turns the expected output into what the tests actually produced, so that the tester can see how the expectation is broken. > > Mentored-by: Christian Couder <chriscool@tuxfamily.org> > Mentored-by: Kaartic Sivaraam <kaartic.sivaraam@gmail.com> > Signed-off-by: Shourya Shukla <shouryashukla.oo@gmail.com> > --- > t/t7401-submodule-summary.sh | 8 ++++---- > 1 file changed, 4 insertions(+), 4 deletions(-) > > diff --git a/t/t7401-submodule-summary.sh b/t/t7401-submodule-summary.sh > index 4439fb7c17..18fefdb0ba 100755 > --- a/t/t7401-submodule-summary.sh > +++ b/t/t7401-submodule-summary.sh > @@ -183,7 +183,7 @@ test_expect_success 'typechanged submodule(submodule->blob), --cached' " > < Add foo5 > > EOF > - test_i18ncmp actual expected > + test_i18ncmp expected actual > " > > test_expect_success 'typechanged submodule(submodule->blob), --files' " > @@ -193,7 +193,7 @@ test_expect_success 'typechanged submodule(submodule->blob), --files' " > > Add foo5 > > EOF > - test_i18ncmp actual expected > + test_i18ncmp expected actual > " > > rm -rf sm1 && > @@ -204,7 +204,7 @@ test_expect_success 'typechanged submodule(submodule->blob)' " > * sm1 $head4(submodule)->$head5(blob): > > EOF > - test_i18ncmp actual expected > + test_i18ncmp expected actual > " > > rm -f sm1 && > @@ -217,7 +217,7 @@ test_expect_success 'nonexistent commit' " > Warn: sm1 doesn't contain commit $head4_full > > EOF > - test_i18ncmp actual expected > + test_i18ncmp expected actual > " > > commit_file
diff --git a/t/t7401-submodule-summary.sh b/t/t7401-submodule-summary.sh index 4439fb7c17..18fefdb0ba 100755 --- a/t/t7401-submodule-summary.sh +++ b/t/t7401-submodule-summary.sh @@ -183,7 +183,7 @@ test_expect_success 'typechanged submodule(submodule->blob), --cached' " < Add foo5 EOF - test_i18ncmp actual expected + test_i18ncmp expected actual " test_expect_success 'typechanged submodule(submodule->blob), --files' " @@ -193,7 +193,7 @@ test_expect_success 'typechanged submodule(submodule->blob), --files' " > Add foo5 EOF - test_i18ncmp actual expected + test_i18ncmp expected actual " rm -rf sm1 && @@ -204,7 +204,7 @@ test_expect_success 'typechanged submodule(submodule->blob)' " * sm1 $head4(submodule)->$head5(blob): EOF - test_i18ncmp actual expected + test_i18ncmp expected actual " rm -f sm1 && @@ -217,7 +217,7 @@ test_expect_success 'nonexistent commit' " Warn: sm1 doesn't contain commit $head4_full EOF - test_i18ncmp actual expected + test_i18ncmp expected actual " commit_file
Change the test_i18ncmp syntax from 'test_i18ncmp actual expected' to 'test_i18ncmp expected actual' to align it with the convention followed by other tests in the test script. Mentored-by: Christian Couder <chriscool@tuxfamily.org> Mentored-by: Kaartic Sivaraam <kaartic.sivaraam@gmail.com> Signed-off-by: Shourya Shukla <shouryashukla.oo@gmail.com> --- t/t7401-submodule-summary.sh | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-)