Message ID | 20220712145850.599666-10-benjamin.tissoires@redhat.com (mailing list archive) |
---|---|
State | Accepted |
Commit | 1e839143d674603b0bbbc4c513bca35404967dbc |
Headers | show |
Series | Introduce eBPF support for HID devices | expand |
On Tue, Jul 12, 2022 at 04:58:36PM +0200, Benjamin Tissoires wrote: > This unique identifier is currently used only for ensuring uniqueness in > sysfs. However, this could be handful for userspace to refer to a specific > hid_device by this id. > > 2 use cases are in my mind: LEDs (and their naming convention), and > HID-BPF. > > Signed-off-by: Benjamin Tissoires <benjamin.tissoires@redhat.com> > Reviewed-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
diff --git a/drivers/hid/hid-core.c b/drivers/hid/hid-core.c index 00154a1cd2d8..11874d264728 100644 --- a/drivers/hid/hid-core.c +++ b/drivers/hid/hid-core.c @@ -2739,10 +2739,12 @@ int hid_add_device(struct hid_device *hdev) hid_warn(hdev, "bad device descriptor (%d)\n", ret); } + hdev->id = atomic_inc_return(&id); + /* XXX hack, any other cleaner solution after the driver core * is converted to allow more than 20 bytes as the device name? */ dev_set_name(&hdev->dev, "%04X:%04X:%04X.%04X", hdev->bus, - hdev->vendor, hdev->product, atomic_inc_return(&id)); + hdev->vendor, hdev->product, hdev->id); hid_debug_register(hdev, dev_name(&hdev->dev)); ret = device_add(&hdev->dev); diff --git a/include/linux/hid.h b/include/linux/hid.h index 4363a63b9775..a43dd17bc78f 100644 --- a/include/linux/hid.h +++ b/include/linux/hid.h @@ -658,6 +658,8 @@ struct hid_device { /* device report descriptor */ struct list_head debug_list; spinlock_t debug_list_lock; wait_queue_head_t debug_wait; + + unsigned int id; /* system unique id */ }; #define to_hid_device(pdev) \
This unique identifier is currently used only for ensuring uniqueness in sysfs. However, this could be handful for userspace to refer to a specific hid_device by this id. 2 use cases are in my mind: LEDs (and their naming convention), and HID-BPF. Signed-off-by: Benjamin Tissoires <benjamin.tissoires@redhat.com> --- no changes in v6 new in v5 --- drivers/hid/hid-core.c | 4 +++- include/linux/hid.h | 2 ++ 2 files changed, 5 insertions(+), 1 deletion(-)