mbox series

[v2,00/13] PCI: aardvark controller fixes

Message ID 20211005180952.6812-1-kabel@kernel.org (mailing list archive)
Headers show
Series PCI: aardvark controller fixes | expand

Message

Marek Behún Oct. 5, 2021, 6:09 p.m. UTC
Hi Lorenzo,

as requested I am sending v2 of this series.

Changes since v1:
- updated commit message in patch 6 as suggested by Mark
- updated patch 6 to also drop the early return
- changed the LTSSM definitions to enum in patch 12
- dropped the Fixes tags for those patches where it was inappropriate

Marek Behún (2):
  PCI: aardvark: Don't spam about PIO Response Status
  PCI: aardvark: Deduplicate code in advk_pcie_rd_conf()

Pali Rohár (11):
  PCI: Add PCI_EXP_DEVCTL_PAYLOAD_* macros
  PCI: aardvark: Fix PCIe Max Payload Size setting
  PCI: aardvark: Fix preserving PCI_EXP_RTCTL_CRSSVE flag on emulated
    bridge
  PCI: aardvark: Fix configuring Reference clock
  PCI: aardvark: Do not clear status bits of masked interrupts
  PCI: aardvark: Do not unmask unused interrupts
  PCI: aardvark: Implement re-issuing config requests on CRS response
  PCI: aardvark: Simplify initialization of rootcap on virtual bridge
  PCI: aardvark: Fix link training
  PCI: aardvark: Fix checking for link up via LTSSM state
  PCI: aardvark: Fix reporting Data Link Layer Link Active

 drivers/pci/controller/pci-aardvark.c | 372 +++++++++++++++-----------
 include/uapi/linux/pci_regs.h         |   6 +
 2 files changed, 217 insertions(+), 161 deletions(-)

Comments

Lorenzo Pieralisi Oct. 7, 2021, 1:38 p.m. UTC | #1
On Tue, 5 Oct 2021 20:09:39 +0200, Marek Behún wrote:
> as requested I am sending v2 of this series.
> 
> Changes since v1:
> - updated commit message in patch 6 as suggested by Mark
> - updated patch 6 to also drop the early return
> - changed the LTSSM definitions to enum in patch 12
> - dropped the Fixes tags for those patches where it was inappropriate
> 
> [...]

I rewrote some logs, dropped some stable tags. This series raised
a couple of interesting questions that may be relevant for PCI core
as well, it'd be great if those won't be lost but I feel it is time
to merge this series to help Marek/Pali cut the patch delta and
give this code wider testing.

I have applied it to pci/aardvark, please _do_ have a look and
report back any issue with it.

[01/13] PCI: Add PCI_EXP_DEVCTL_PAYLOAD_* macros
        https://git.kernel.org/lpieralisi/pci/c/460275f124
[02/13] PCI: aardvark: Fix PCIe Max Payload Size setting
        https://git.kernel.org/lpieralisi/pci/c/a4e17d65da
[03/13] PCI: aardvark: Don't spam about PIO Response Status
        https://git.kernel.org/lpieralisi/pci/c/464de7e7ff
[04/13] PCI: aardvark: Fix preserving PCI_EXP_RTCTL_CRSSVE flag on emulated bridge
        https://git.kernel.org/lpieralisi/pci/c/d419052bc6
[05/13] PCI: aardvark: Fix configuring Reference clock
        https://git.kernel.org/lpieralisi/pci/c/46ef6090db
[06/13] PCI: aardvark: Do not clear status bits of masked interrupts
        https://git.kernel.org/lpieralisi/pci/c/a7ca6d7fa3
[07/13] PCI: aardvark: Do not unmask unused interrupts
        https://git.kernel.org/lpieralisi/pci/c/1fb95d7d3c
[08/13] PCI: aardvark: Deduplicate code in advk_pcie_rd_conf()
        https://git.kernel.org/lpieralisi/pci/c/67cb2a4c93
[09/13] PCI: aardvark: Implement re-issuing config requests on CRS response
        https://git.kernel.org/lpieralisi/pci/c/223dec14a0
[10/13] PCI: aardvark: Simplify initialization of rootcap on virtual bridge
        https://git.kernel.org/lpieralisi/pci/c/454c53271f
[11/13] PCI: aardvark: Fix link training
        https://git.kernel.org/lpieralisi/pci/c/f76b36d40b
[12/13] PCI: aardvark: Fix checking for link up via LTSSM state
        https://git.kernel.org/lpieralisi/pci/c/661c399a65
[13/13] PCI: aardvark: Fix reporting Data Link Layer Link Active
        https://git.kernel.org/lpieralisi/pci/c/2b650b7ff2

Thanks,
Lorenzo
Marek Behún Oct. 7, 2021, 5:36 p.m. UTC | #2
On Thu,  7 Oct 2021 14:38:25 +0100
Lorenzo Pieralisi <lorenzo.pieralisi@arm.com> wrote:

> On Tue, 5 Oct 2021 20:09:39 +0200, Marek Behún wrote:
> > as requested I am sending v2 of this series.
> > 
> > Changes since v1:
> > - updated commit message in patch 6 as suggested by Mark
> > - updated patch 6 to also drop the early return
> > - changed the LTSSM definitions to enum in patch 12
> > - dropped the Fixes tags for those patches where it was inappropriate
> > 
> > [...]  
> 
> I rewrote some logs, dropped some stable tags. This series raised
> a couple of interesting questions that may be relevant for PCI core
> as well, it'd be great if those won't be lost but I feel it is time
> to merge this series to help Marek/Pali cut the patch delta and
> give this code wider testing.
> 
> I have applied it to pci/aardvark, please _do_ have a look and
> report back any issue with it.

I checked all the commit messages in pci/aardvark.

I also compiled this branch and tested it on my Mox with ath10k card
and it works correctly, no regressions.

Marek