mbox series

[v2,0/6] PCI: imx6: rename\clean up and add lut information for imx95

Message ID 20240304-pci2_upstream-v2-0-ad07c5eb6d67@nxp.com (mailing list archive)
Headers show
Series PCI: imx6: rename\clean up and add lut information for imx95 | expand

Message

Frank Li March 4, 2024, 8:25 p.m. UTC
imx6 actaully for all imx chips (imx6*, imx7*, imx8*, imx9*). To avoid     
confuse, rename all imx6_* to imx_*, IMX6_* to IMX_*. pci-imx6.c to        
pci-imx.c to avoid confuse.                                                

Using callback to reduce switch case for core reset and refclk.            

Add imx95 iommux and its stream id information.                            

Base on linux-pci/controller/imx

Signed-off-by: Frank Li <Frank.Li@nxp.com>
---
Changes in v2:
- remove file to 'pcie-imx.c'
- keep CONFIG unchange.
- Link to v1: https://lore.kernel.org/r/20240227-pci2_upstream-v1-0-b952f8333606@nxp.com

---
Frank Li (6):
      PCI: imx6: Rename imx6_* with imx_*
      PCI: imx6: Rename pci-imx6.c to pcie-imx.c
      MAINTAINERS: pci: imx: update imx6* to imx* since rename driver file
      PCI: imx: Simplify switch-case logic by involve set_ref_clk callback
      PCI: imx: Simplify switch-case logic by involve core_reset callback
      PCI: imx: Config look up table(LUT) to support MSI ITS and IOMMU for i.MX95

 MAINTAINERS                                        |    4 +-
 drivers/pci/controller/dwc/Makefile                |    2 +-
 .../pci/controller/dwc/{pci-imx6.c => pcie-imx.c}  | 1115 +++++++++++---------
 3 files changed, 647 insertions(+), 474 deletions(-)
---
base-commit: 0a580c33494a7d293ff0d34cf4db4af107070ccf
change-id: 20240227-pci2_upstream-0cdd19a15163

Best regards,

Comments

Frank Li March 19, 2024, 4:22 p.m. UTC | #1
On Mon, Mar 04, 2024 at 03:25:05PM -0500, Frank Li wrote:
> imx6 actaully for all imx chips (imx6*, imx7*, imx8*, imx9*). To avoid     
> confuse, rename all imx6_* to imx_*, IMX6_* to IMX_*. pci-imx6.c to        
> pci-imx.c to avoid confuse.                                                
> 
> Using callback to reduce switch case for core reset and refclk.            
> 
> Add imx95 iommux and its stream id information.                            
> 
> Base on linux-pci/controller/imx
> 
> Signed-off-by: Frank Li <Frank.Li@nxp.com>

Add manivannan to TO list.

@mani:
	Could you please help review these patches? 

Frank

> ---
> Changes in v2:
> - remove file to 'pcie-imx.c'
> - keep CONFIG unchange.
> - Link to v1: https://lore.kernel.org/r/20240227-pci2_upstream-v1-0-b952f8333606@nxp.com
> 
> ---
> Frank Li (6):
>       PCI: imx6: Rename imx6_* with imx_*
>       PCI: imx6: Rename pci-imx6.c to pcie-imx.c
>       MAINTAINERS: pci: imx: update imx6* to imx* since rename driver file
>       PCI: imx: Simplify switch-case logic by involve set_ref_clk callback
>       PCI: imx: Simplify switch-case logic by involve core_reset callback
>       PCI: imx: Config look up table(LUT) to support MSI ITS and IOMMU for i.MX95
> 
>  MAINTAINERS                                        |    4 +-
>  drivers/pci/controller/dwc/Makefile                |    2 +-
>  .../pci/controller/dwc/{pci-imx6.c => pcie-imx.c}  | 1115 +++++++++++---------
>  3 files changed, 647 insertions(+), 474 deletions(-)
> ---
> base-commit: 0a580c33494a7d293ff0d34cf4db4af107070ccf
> change-id: 20240227-pci2_upstream-0cdd19a15163
> 
> Best regards,
> -- 
> Frank Li <Frank.Li@nxp.com>
>