Message ID | 20241113202214.1421739-1-jperaza@google.com (mailing list archive) |
---|---|
Headers | show |
Series | PCI/ACPI: Support Microsoft's "DmaProperty" | expand |
On Wed, Nov 13, 2024 at 12:22 PM Joshua Peraza <jperaza@google.com> wrote: > > This patchset rebases two previously posted patches supporting > recognition of Microsoft's DmaProperty. > > Rajat Jain (2): > PCI/ACPI: Support Microsoft's "DmaProperty" > PCI: Rename pci_dev->untrusted to pci_dev->untrusted_dma Thanks for resending. This probably dropped off my radar since I moved on to other things. But I can confirm a lot of Chromebooks today in the market already use this property (and this patchset) for identifying untrusted DMA capable devices. Thanks & Best Regards, Rajat > > drivers/acpi/property.c | 3 +++ > drivers/iommu/amd/iommu.c | 2 +- > drivers/iommu/dma-iommu.c | 12 ++++++------ > drivers/iommu/intel/iommu.c | 2 +- > drivers/iommu/iommu.c | 2 +- > drivers/pci/ats.c | 2 +- > drivers/pci/pci-acpi.c | 22 ++++++++++++++++++++++ > drivers/pci/pci.c | 2 +- > drivers/pci/probe.c | 8 ++++---- > drivers/pci/quirks.c | 2 +- > include/linux/pci.h | 5 +++-- > 11 files changed, 44 insertions(+), 18 deletions(-) > > > base-commit: 2d5404caa8c7bb5c4e0435f94b28834ae5456623 > -- > 2.47.0.277.g8800431eea-goog >
On Wed, Nov 13, 2024 at 08:22:12PM +0000, Joshua Peraza wrote: > This patchset rebases two previously posted patches supporting > recognition of Microsoft's DmaProperty. > > Rajat Jain (2): > PCI/ACPI: Support Microsoft's "DmaProperty" > PCI: Rename pci_dev->untrusted to pci_dev->untrusted_dma I thought we went through a lot of different choices when picking this name, and explicitly did NOT use the "_dma" term here for a reason. Can you go and read those old patch submissions to verify why we did so, and what has changed since then and then document here what has changed to allow this name change now? thanks, greg k-h