mbox series

[0/9] Improve Synopsys DesignWare Root Complex driver code

Message ID cover.1547631485.git.gustavo.pimentel@synopsys.com (mailing list archive)
Headers show
Series Improve Synopsys DesignWare Root Complex driver code | expand

Message

Gustavo Pimentel Jan. 16, 2019, 10:14 a.m. UTC
This patch series aims to improve Synopsys DesignWare Root Complex driver
code by:
 - removing unnecessary header files
 - enforcing variable naming coherency among similar functions
 - simplifing code readability of mask/unmask function operations
 - replacing bit rotation operation (1 << bit) by BIT(bit)
 - adding a pointer null validation on dw_pcie_irq_domain_free()

No functional changes are intended.

All patches are independent so they can be easily analyzed and accepted or
discarded.

This patches organization also allows to easily merge (squash) some patches,
if desired.

Signed-off-by: Gustavo Pimentel <gustavo.pimentel@synopsys.com>
Cc: Lorenzo Pieralisi <lorenzo.pieralisi@arm.com>
Cc: Joao Pinto <jpinto@synopsys.com>
Cc: Jingoo Han <jingoohan1@gmail.com>

Gustavo Pimentel (9):
  PCI: dwc: Remove unnecessary header include (of_gpio.h)
  PCI: dwc: Remove unnecessary header include (signal.h)
  PCI: dwc: Replace variable name from data to d on
    dw_pci_bottom_mask/unmask()
  PCI: dwc: Replace variable name from data to d on
    dw_pci_setup_msi_msg()
  PCI: dwc: Replace variable name from data to d on
    dw_pci_msi_set_affinity()
  PCI: dwc: Replace variable name from data to d on
    dw_pcie_irq_domain_free()
  PCI: dwc: Improve code readability and simplifies mask/unmask
    operations
  PCI: dwc: Replace bit rotation operation (1 << bit) by BIT(bit)
  PCI: dwc: Add pcie port pointer validation

 drivers/pci/controller/dwc/pcie-designware-host.c | 57 ++++++++++++-----------
 drivers/pci/controller/dwc/pcie-designware-plat.c |  2 -
 drivers/pci/controller/dwc/pcie-designware.h      |  2 +-
 3 files changed, 32 insertions(+), 29 deletions(-)