Message ID | 1480675020-26346-4-git-send-email-horms+renesas@verge.net.au (mailing list archive) |
---|---|
State | New, archived |
Delegated to: | Bjorn Helgaas |
Headers | show |
On Fri, Dec 2, 2016 at 11:37 AM, Simon Horman <horms+renesas@verge.net.au> wrote: > Add fallback compatibility string for the R-Car Gen 3 family. This is in > keeping with the both the existing fallback compatibility string for the > R-Car Gen 2 family and the fallback scheme being adopted wherever > appropriate for drivers for Renesas SoCs. > > Signed-off-by: Simon Horman <horms+renesas@verge.net.au> Reviewed-by: Geert Uytterhoeven <geert+renesas@glider.be> Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds -- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On Fri, Dec 02, 2016 at 11:37:00AM +0100, Simon Horman wrote: > Add fallback compatibility string for the R-Car Gen 3 family. This is in > keeping with the both the existing fallback compatibility string for the > R-Car Gen 2 family and the fallback scheme being adopted wherever > appropriate for drivers for Renesas SoCs. > > Signed-off-by: Simon Horman <horms+renesas@verge.net.au> > --- > v2 > * Move fallback binding to below SoC specific bindings it covers > in implementation > --- > Documentation/devicetree/bindings/pci/rcar-pci.txt | 1 + > drivers/pci/host/pcie-rcar.c | 2 ++ > 2 files changed, 3 insertions(+) > > diff --git a/Documentation/devicetree/bindings/pci/rcar-pci.txt b/Documentation/devicetree/bindings/pci/rcar-pci.txt > index 6cf99690eef9..eee518db90b9 100644 > --- a/Documentation/devicetree/bindings/pci/rcar-pci.txt > +++ b/Documentation/devicetree/bindings/pci/rcar-pci.txt > @@ -7,6 +7,7 @@ compatible: "renesas,pcie-r8a7779" for the R8A7779 SoC; > "renesas,pcie-r8a7793" for the R8A7793 SoC; > "renesas,pcie-r8a7795" for the R8A7795 SoC; > "renesas,pcie-rcar-gen2" for a generic R-Car Gen2 compatible device. > + "renesas,pcie-rcar-gen3" for a generic R-Car Gen3 compatible device. > > When compatible with the generic version, nodes must list the > SoC-specific version corresponding to the platform first > diff --git a/drivers/pci/host/pcie-rcar.c b/drivers/pci/host/pcie-rcar.c > index 85971bc276c6..72058bc7af5c 100644 > --- a/drivers/pci/host/pcie-rcar.c > +++ b/drivers/pci/host/pcie-rcar.c > @@ -1078,6 +1078,8 @@ static const struct of_device_id rcar_pcie_of_match[] = { > { .compatible = "renesas,pcie-rcar-gen2", > .data = rcar_pcie_hw_init_gen2 }, > { .compatible = "renesas,pcie-r8a7795", .data = rcar_pcie_hw_init }, > + { .compatible = "renesas,pcie-rcar-gen3", > + .data = rcar_pcie_hw_init_hw_init }, It looks like I failed to compile-test this. s/rcar_pcie_hw_init_hw_init/rcar_pcie_hw_init/ > {}, > }; > > -- > 2.7.0.rc3.207.g0ac5344 > -- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On Fri, Dec 2, 2016 at 10:50 PM, Simon Horman <horms@verge.net.au> wrote: > On Fri, Dec 02, 2016 at 11:37:00AM +0100, Simon Horman wrote: >> --- a/drivers/pci/host/pcie-rcar.c >> +++ b/drivers/pci/host/pcie-rcar.c >> @@ -1078,6 +1078,8 @@ static const struct of_device_id rcar_pcie_of_match[] = { >> { .compatible = "renesas,pcie-rcar-gen2", >> .data = rcar_pcie_hw_init_gen2 }, >> { .compatible = "renesas,pcie-r8a7795", .data = rcar_pcie_hw_init }, >> + { .compatible = "renesas,pcie-rcar-gen3", >> + .data = rcar_pcie_hw_init_hw_init }, > > It looks like I failed to compile-test this. > > s/rcar_pcie_hw_init_hw_init/rcar_pcie_hw_init/ Bummer, and my tired eyes didn't notice... Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds -- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/Documentation/devicetree/bindings/pci/rcar-pci.txt b/Documentation/devicetree/bindings/pci/rcar-pci.txt index 6cf99690eef9..eee518db90b9 100644 --- a/Documentation/devicetree/bindings/pci/rcar-pci.txt +++ b/Documentation/devicetree/bindings/pci/rcar-pci.txt @@ -7,6 +7,7 @@ compatible: "renesas,pcie-r8a7779" for the R8A7779 SoC; "renesas,pcie-r8a7793" for the R8A7793 SoC; "renesas,pcie-r8a7795" for the R8A7795 SoC; "renesas,pcie-rcar-gen2" for a generic R-Car Gen2 compatible device. + "renesas,pcie-rcar-gen3" for a generic R-Car Gen3 compatible device. When compatible with the generic version, nodes must list the SoC-specific version corresponding to the platform first diff --git a/drivers/pci/host/pcie-rcar.c b/drivers/pci/host/pcie-rcar.c index 85971bc276c6..72058bc7af5c 100644 --- a/drivers/pci/host/pcie-rcar.c +++ b/drivers/pci/host/pcie-rcar.c @@ -1078,6 +1078,8 @@ static const struct of_device_id rcar_pcie_of_match[] = { { .compatible = "renesas,pcie-rcar-gen2", .data = rcar_pcie_hw_init_gen2 }, { .compatible = "renesas,pcie-r8a7795", .data = rcar_pcie_hw_init }, + { .compatible = "renesas,pcie-rcar-gen3", + .data = rcar_pcie_hw_init_hw_init }, {}, };
Add fallback compatibility string for the R-Car Gen 3 family. This is in keeping with the both the existing fallback compatibility string for the R-Car Gen 2 family and the fallback scheme being adopted wherever appropriate for drivers for Renesas SoCs. Signed-off-by: Simon Horman <horms+renesas@verge.net.au> --- v2 * Move fallback binding to below SoC specific bindings it covers in implementation --- Documentation/devicetree/bindings/pci/rcar-pci.txt | 1 + drivers/pci/host/pcie-rcar.c | 2 ++ 2 files changed, 3 insertions(+)