Message ID | 20211128025051.355578-3-baolu.lu@linux.intel.com (mailing list archive) |
---|---|
State | Superseded |
Delegated to: | Bjorn Helgaas |
Headers | show |
Series | Fix BUG_ON in vfio_iommu_group_notifier() | expand |
On Sun, Nov 28, 2021 at 10:50:36AM +0800, Lu Baolu wrote: > The bus_type structure defines dma_configure() callback for bus drivers > to configure DMA on the devices. This adds the paired dma_unconfigure() > callback and calls it during driver unbinding so that bus drivers can do > some cleanup work. > > One use case for this paired DMA callbacks is for the bus driver to check > for DMA ownership conflicts during driver binding, where multiple devices > belonging to a same IOMMU group (the minimum granularity of isolation and > protection) may be assigned to kernel drivers or user space respectively. > > Without this change, for example, the vfio driver has to listen to a bus > BOUND_DRIVER event and then BUG_ON() in case of dma ownership conflict. > This leads to bad user experience since careless driver binding operation > may crash the system if the admin overlooks the group restriction. Aside > from bad design, this leads to a security problem as a root user, even with > lockdown=integrity, can force the kernel to BUG. > > With this change, the bus driver could check and set the DMA ownership in > driver binding process and fail on ownership conflicts. The DMA ownership > should be released during driver unbinding. > > Suggested-by: Jason Gunthorpe <jgg@nvidia.com> > Link: https://lore.kernel.org/linux-iommu/20210922123931.GI327412@nvidia.com/ > Link: https://lore.kernel.org/linux-iommu/20210928115751.GK964074@nvidia.com/ > Signed-off-by: Lu Baolu <baolu.lu@linux.intel.com> > --- > include/linux/device/bus.h | 3 +++ > drivers/base/dd.c | 7 ++++++- > 2 files changed, 9 insertions(+), 1 deletion(-) > > diff --git a/include/linux/device/bus.h b/include/linux/device/bus.h > index a039ab809753..ef54a71e5f8f 100644 > --- a/include/linux/device/bus.h > +++ b/include/linux/device/bus.h > @@ -59,6 +59,8 @@ struct fwnode_handle; > * bus supports. > * @dma_configure: Called to setup DMA configuration on a device on > * this bus. > + * @dma_unconfigure: Called to cleanup DMA configuration on a device on > + * this bus. "dma_cleanup()" is a better name for this, don't you think? thanks, greg k-h
On 11/28/21 4:02 PM, Greg Kroah-Hartman wrote: > On Sun, Nov 28, 2021 at 10:50:36AM +0800, Lu Baolu wrote: >> The bus_type structure defines dma_configure() callback for bus drivers >> to configure DMA on the devices. This adds the paired dma_unconfigure() >> callback and calls it during driver unbinding so that bus drivers can do >> some cleanup work. >> >> One use case for this paired DMA callbacks is for the bus driver to check >> for DMA ownership conflicts during driver binding, where multiple devices >> belonging to a same IOMMU group (the minimum granularity of isolation and >> protection) may be assigned to kernel drivers or user space respectively. >> >> Without this change, for example, the vfio driver has to listen to a bus >> BOUND_DRIVER event and then BUG_ON() in case of dma ownership conflict. >> This leads to bad user experience since careless driver binding operation >> may crash the system if the admin overlooks the group restriction. Aside >> from bad design, this leads to a security problem as a root user, even with >> lockdown=integrity, can force the kernel to BUG. >> >> With this change, the bus driver could check and set the DMA ownership in >> driver binding process and fail on ownership conflicts. The DMA ownership >> should be released during driver unbinding. >> >> Suggested-by: Jason Gunthorpe <jgg@nvidia.com> >> Link: https://lore.kernel.org/linux-iommu/20210922123931.GI327412@nvidia.com/ >> Link: https://lore.kernel.org/linux-iommu/20210928115751.GK964074@nvidia.com/ >> Signed-off-by: Lu Baolu <baolu.lu@linux.intel.com> >> --- >> include/linux/device/bus.h | 3 +++ >> drivers/base/dd.c | 7 ++++++- >> 2 files changed, 9 insertions(+), 1 deletion(-) >> >> diff --git a/include/linux/device/bus.h b/include/linux/device/bus.h >> index a039ab809753..ef54a71e5f8f 100644 >> --- a/include/linux/device/bus.h >> +++ b/include/linux/device/bus.h >> @@ -59,6 +59,8 @@ struct fwnode_handle; >> * bus supports. >> * @dma_configure: Called to setup DMA configuration on a device on >> * this bus. >> + * @dma_unconfigure: Called to cleanup DMA configuration on a device on >> + * this bus. > > "dma_cleanup()" is a better name for this, don't you think? I agree with you. dma_cleanup() is more explicit and better here. > > thanks, > > greg k-h > Best regards, baolu
diff --git a/include/linux/device/bus.h b/include/linux/device/bus.h index a039ab809753..ef54a71e5f8f 100644 --- a/include/linux/device/bus.h +++ b/include/linux/device/bus.h @@ -59,6 +59,8 @@ struct fwnode_handle; * bus supports. * @dma_configure: Called to setup DMA configuration on a device on * this bus. + * @dma_unconfigure: Called to cleanup DMA configuration on a device on + * this bus. * @pm: Power management operations of this bus, callback the specific * device driver's pm-ops. * @iommu_ops: IOMMU specific operations for this bus, used to attach IOMMU @@ -103,6 +105,7 @@ struct bus_type { int (*num_vf)(struct device *dev); int (*dma_configure)(struct device *dev); + void (*dma_unconfigure)(struct device *dev); const struct dev_pm_ops *pm; diff --git a/drivers/base/dd.c b/drivers/base/dd.c index 68ea1f949daa..a37aafff5fde 100644 --- a/drivers/base/dd.c +++ b/drivers/base/dd.c @@ -577,7 +577,7 @@ static int really_probe(struct device *dev, struct device_driver *drv) if (dev->bus->dma_configure) { ret = dev->bus->dma_configure(dev); if (ret) - goto probe_failed; + goto pinctrl_bind_failed; } ret = driver_sysfs_add(dev); @@ -660,6 +660,8 @@ static int really_probe(struct device *dev, struct device_driver *drv) if (dev->bus) blocking_notifier_call_chain(&dev->bus->p->bus_notifier, BUS_NOTIFY_DRIVER_NOT_BOUND, dev); + if (dev->bus->dma_unconfigure) + dev->bus->dma_unconfigure(dev); pinctrl_bind_failed: device_links_no_driver(dev); devres_release_all(dev); @@ -1204,6 +1206,9 @@ static void __device_release_driver(struct device *dev, struct device *parent) else if (drv->remove) drv->remove(dev); + if (dev->bus->dma_unconfigure) + dev->bus->dma_unconfigure(dev); + device_links_driver_cleanup(dev); devres_release_all(dev);
The bus_type structure defines dma_configure() callback for bus drivers to configure DMA on the devices. This adds the paired dma_unconfigure() callback and calls it during driver unbinding so that bus drivers can do some cleanup work. One use case for this paired DMA callbacks is for the bus driver to check for DMA ownership conflicts during driver binding, where multiple devices belonging to a same IOMMU group (the minimum granularity of isolation and protection) may be assigned to kernel drivers or user space respectively. Without this change, for example, the vfio driver has to listen to a bus BOUND_DRIVER event and then BUG_ON() in case of dma ownership conflict. This leads to bad user experience since careless driver binding operation may crash the system if the admin overlooks the group restriction. Aside from bad design, this leads to a security problem as a root user, even with lockdown=integrity, can force the kernel to BUG. With this change, the bus driver could check and set the DMA ownership in driver binding process and fail on ownership conflicts. The DMA ownership should be released during driver unbinding. Suggested-by: Jason Gunthorpe <jgg@nvidia.com> Link: https://lore.kernel.org/linux-iommu/20210922123931.GI327412@nvidia.com/ Link: https://lore.kernel.org/linux-iommu/20210928115751.GK964074@nvidia.com/ Signed-off-by: Lu Baolu <baolu.lu@linux.intel.com> --- include/linux/device/bus.h | 3 +++ drivers/base/dd.c | 7 ++++++- 2 files changed, 9 insertions(+), 1 deletion(-)