mbox series

[PATCHv2,for-next,00/19] Misc update for rtrs

Message ID 20201217141915.56989-1-jinpu.wang@cloud.ionos.com (mailing list archive)
Headers show
Series Misc update for rtrs | expand

Message

Jinpu Wang Dec. 17, 2020, 2:18 p.m. UTC
Hi Jason, hi Doug,

Please consider to include following changes to the next merge window.

It contains a few bugfix and cleanup:
- Fix memory leak incase of failure in kobj_init_and_add in both clt/srv
- reduce memory footprint by set proper limit when create QP
- fix missing wr_cqe in a few cases on srv, it could lead to crash in error
  case.
- remove the SIGNAL flag for heartbeat, otherwise it could mess around 
the send_wr_awail accouting.
- flush on going session closing to release the memory presure on server.
- other misc fix and cleanup.

The patches are created based on rdma/for-next.

V2->V1
* more descprition for the patches above as requested by Jason, also include
Fixes tag for bugfix.
* suppress the lockdep warning for PATCH 2 `Occasionally flush ongoing session closing`
with comment.
* new bugfix PATCH 19 RDMA/rtrs: Fix KASAN: stack-out-of-bounds bug

Thanks!

Guoqing Jiang (8):
  RDMA/rtrs-srv: Jump to dereg_mr label if allocate iu fails
  RDMA/rtrs: Call kobject_put in the failure path
  RDMA/rtrs-clt: Consolidate rtrs_clt_destroy_sysfs_root_{folder,files}
  RDMA/rtrs-clt: Kill wait_for_inflight_permits
  RDMA/rtrs-clt: Remove unnecessary 'goto out'
  RDMA/rtrs-clt: Kill rtrs_clt_change_state
  RDMA/rtrs-clt: Rename __rtrs_clt_change_state to rtrs_clt_change_state
  RDMA/rtrs-clt: Refactor the failure cases in alloc_clt

Jack Wang (11):
  RDMA/rtrs: Extend ibtrs_cq_qp_create
  RMDA/rtrs-srv: Occasionally flush ongoing session closing
  RDMA/rtrs-srv: Release lock before call into close_sess
  RDMA/rtrs-srv: Use sysfs_remove_file_self for disconnect
  RDMA/rtrs-clt: Set mininum limit when create QP
  RDMA/rtrs-srv: Fix missing wr_cqe
  RDMA/rtrs: Do not signal for heatbeat
  RDMA/rtrs-clt: Use bitmask to check sess->flags
  RDMA/rtrs-srv: Do not signal REG_MR
  RDMA/rtrs-srv: Init wr_cnt as 1
  RDMA/rtrs: Fix KASAN: stack-out-of-bounds bug

 drivers/infiniband/ulp/rtrs/rtrs-clt-sysfs.c |  11 +-
 drivers/infiniband/ulp/rtrs/rtrs-clt.c       | 120 +++++++++----------
 drivers/infiniband/ulp/rtrs/rtrs-clt.h       |   3 +-
 drivers/infiniband/ulp/rtrs/rtrs-pri.h       |   5 +-
 drivers/infiniband/ulp/rtrs/rtrs-srv-sysfs.c |   5 +-
 drivers/infiniband/ulp/rtrs/rtrs-srv.c       |  34 ++++--
 drivers/infiniband/ulp/rtrs/rtrs.c           |  32 ++---
 7 files changed, 110 insertions(+), 100 deletions(-)

Comments

Jinpu Wang Jan. 11, 2021, 7:04 a.m. UTC | #1
On Thu, Dec 17, 2020 at 3:19 PM Jack Wang <jinpu.wang@cloud.ionos.com> wrote:
>
> Hi Jason, hi Doug,
>
> Please consider to include following changes to the next merge window.
>
> It contains a few bugfix and cleanup:
> - Fix memory leak incase of failure in kobj_init_and_add in both clt/srv
> - reduce memory footprint by set proper limit when create QP
> - fix missing wr_cqe in a few cases on srv, it could lead to crash in error
>   case.
> - remove the SIGNAL flag for heartbeat, otherwise it could mess around
> the send_wr_awail accouting.
> - flush on going session closing to release the memory presure on server.
> - other misc fix and cleanup.
>
> The patches are created based on rdma/for-next.
Hi Jason,

ping, any comments or do you need a resend/rebase?

Thanks!

>
> V2->V1
> * more descprition for the patches above as requested by Jason, also include
> Fixes tag for bugfix.
> * suppress the lockdep warning for PATCH 2 `Occasionally flush ongoing session closing`
> with comment.
> * new bugfix PATCH 19 RDMA/rtrs: Fix KASAN: stack-out-of-bounds bug
>
> Thanks!
>
> Guoqing Jiang (8):
>   RDMA/rtrs-srv: Jump to dereg_mr label if allocate iu fails
>   RDMA/rtrs: Call kobject_put in the failure path
>   RDMA/rtrs-clt: Consolidate rtrs_clt_destroy_sysfs_root_{folder,files}
>   RDMA/rtrs-clt: Kill wait_for_inflight_permits
>   RDMA/rtrs-clt: Remove unnecessary 'goto out'
>   RDMA/rtrs-clt: Kill rtrs_clt_change_state
>   RDMA/rtrs-clt: Rename __rtrs_clt_change_state to rtrs_clt_change_state
>   RDMA/rtrs-clt: Refactor the failure cases in alloc_clt
>
> Jack Wang (11):
>   RDMA/rtrs: Extend ibtrs_cq_qp_create
>   RMDA/rtrs-srv: Occasionally flush ongoing session closing
>   RDMA/rtrs-srv: Release lock before call into close_sess
>   RDMA/rtrs-srv: Use sysfs_remove_file_self for disconnect
>   RDMA/rtrs-clt: Set mininum limit when create QP
>   RDMA/rtrs-srv: Fix missing wr_cqe
>   RDMA/rtrs: Do not signal for heatbeat
>   RDMA/rtrs-clt: Use bitmask to check sess->flags
>   RDMA/rtrs-srv: Do not signal REG_MR
>   RDMA/rtrs-srv: Init wr_cnt as 1
>   RDMA/rtrs: Fix KASAN: stack-out-of-bounds bug
>
>  drivers/infiniband/ulp/rtrs/rtrs-clt-sysfs.c |  11 +-
>  drivers/infiniband/ulp/rtrs/rtrs-clt.c       | 120 +++++++++----------
>  drivers/infiniband/ulp/rtrs/rtrs-clt.h       |   3 +-
>  drivers/infiniband/ulp/rtrs/rtrs-pri.h       |   5 +-
>  drivers/infiniband/ulp/rtrs/rtrs-srv-sysfs.c |   5 +-
>  drivers/infiniband/ulp/rtrs/rtrs-srv.c       |  34 ++++--
>  drivers/infiniband/ulp/rtrs/rtrs.c           |  32 ++---
>  7 files changed, 110 insertions(+), 100 deletions(-)
>
> --
> 2.25.1
>
Jason Gunthorpe Jan. 15, 2021, 7:48 p.m. UTC | #2
On Thu, Dec 17, 2020 at 03:18:56PM +0100, Jack Wang wrote:
> Hi Jason, hi Doug,
> 
> Please consider to include following changes to the next merge window.
> 
> It contains a few bugfix and cleanup:
> - Fix memory leak incase of failure in kobj_init_and_add in both clt/srv
> - reduce memory footprint by set proper limit when create QP
> - fix missing wr_cqe in a few cases on srv, it could lead to crash in error
>   case.
> - remove the SIGNAL flag for heartbeat, otherwise it could mess around 
> the send_wr_awail accouting.
> - flush on going session closing to release the memory presure on server.
> - other misc fix and cleanup.
> 
> The patches are created based on rdma/for-next.
> 
> V2->V1
> * more descprition for the patches above as requested by Jason, also include
> Fixes tag for bugfix.
> * suppress the lockdep warning for PATCH 2 `Occasionally flush ongoing session closing`
> with comment.
> * new bugfix PATCH 19 RDMA/rtrs: Fix KASAN: stack-out-of-bounds bug
> 
> Thanks!
> 
> Guoqing Jiang (8):
>   RDMA/rtrs-srv: Jump to dereg_mr label if allocate iu fails
>   RDMA/rtrs: Call kobject_put in the failure path
>   RDMA/rtrs-clt: Consolidate rtrs_clt_destroy_sysfs_root_{folder,files}
>   RDMA/rtrs-clt: Kill wait_for_inflight_permits
>   RDMA/rtrs-clt: Remove unnecessary 'goto out'
>   RDMA/rtrs-clt: Kill rtrs_clt_change_state
>   RDMA/rtrs-clt: Rename __rtrs_clt_change_state to rtrs_clt_change_state
>   RDMA/rtrs-clt: Refactor the failure cases in alloc_clt
> 
> Jack Wang (11):
>   RDMA/rtrs: Extend ibtrs_cq_qp_create
>   RDMA/rtrs-srv: Release lock before call into close_sess
>   RDMA/rtrs-srv: Use sysfs_remove_file_self for disconnect
>   RDMA/rtrs-clt: Set mininum limit when create QP
>   RDMA/rtrs-srv: Fix missing wr_cqe
>   RDMA/rtrs: Do not signal for heatbeat
>   RDMA/rtrs-clt: Use bitmask to check sess->flags
>   RDMA/rtrs-srv: Do not signal REG_MR
>   RDMA/rtrs-srv: Init wr_cnt as 1
>   RDMA/rtrs: Fix KASAN: stack-out-of-bounds bug

Every one except:

>   RMDA/rtrs-srv: Occasionally flush ongoing session closing

Applied to for-next, thanks

Jason