mbox series

[PATCHv3,for-next,0/5] Misc update for RTRS

Message ID 20210614090337.29557-1-jinpu.wang@ionos.com (mailing list archive)
Headers show
Series Misc update for RTRS | expand

Message

Jinpu Wang June 14, 2021, 9:03 a.m. UTC
Hi Jason, hi Doug,

Please consider to include following changes to the next merge window.
It contains:
- first 2 patches are for reducing the memory usage when create QP.
- the third one are to make testing on RXE working.
- the fourth one is just cleanup for variables.
- the last one is new to check max_qp_wr as suggested by Leon

v3->v2:
- added R-b from Leon for all 5 patches.
- s/NOMEM/ENOMEM in patch3 commit message as suggested by Leon.
- Rephrase the commit message for the renaming (patch4) as suggested by Leon
v2->v1:
- A new patch to check device map_qp_wr when create QP.

v2: https://lore.kernel.org/linux-rdma/20210611121034.48837-1-jinpu.wang@ionos.com/T/#t
v1: https://lore.kernel.org/linux-rdma/20210608103039.39080-1-jinpu.wang@ionos.com/T/#t

This patchset is based on rdma/for-next branch.

Note: I tried the patchset for fast memory registration on write path can still apply.
https://lore.kernel.org/linux-rdma/20210608113536.42965-1-jinpu.wang@ionos.com/T/#t

Thanks!

Guoqing Jiang (1):
  RDMA/rtrs: Rename cq_size/queue_size to cq_num/queue_num

Jack Wang (3):
  RDMA/rtrs-srv: Set minimal max_send_wr and max_recv_wr
  RDMA/rtrs-clt: Use minimal max_send_sge when create qp
  RDMA/rtrs: Check device max_qp_wr limit when create QP

Md Haris Iqbal (1):
  RDMA/rtrs: RDMA_RXE requires more number of WR

 drivers/infiniband/ulp/rtrs/rtrs-clt.c | 50 ++++++++++++++------------
 drivers/infiniband/ulp/rtrs/rtrs-clt.h |  3 +-
 drivers/infiniband/ulp/rtrs/rtrs-pri.h | 10 +++---
 drivers/infiniband/ulp/rtrs/rtrs-srv.c | 34 ++++++++++--------
 drivers/infiniband/ulp/rtrs/rtrs.c     | 24 ++++++-------
 5 files changed, 65 insertions(+), 56 deletions(-)

Comments

Jason Gunthorpe June 18, 2021, 4:51 p.m. UTC | #1
On Mon, Jun 14, 2021 at 11:03:32AM +0200, Jack Wang wrote:
> Hi Jason, hi Doug,
> 
> Please consider to include following changes to the next merge window.
> It contains:
> - first 2 patches are for reducing the memory usage when create QP.
> - the third one are to make testing on RXE working.
> - the fourth one is just cleanup for variables.
> - the last one is new to check max_qp_wr as suggested by Leon
> 
> v3->v2:
> - added R-b from Leon for all 5 patches.
> - s/NOMEM/ENOMEM in patch3 commit message as suggested by Leon.
> - Rephrase the commit message for the renaming (patch4) as suggested by Leon
> v2->v1:
> - A new patch to check device map_qp_wr when create QP.
> 
> v2: https://lore.kernel.org/linux-rdma/20210611121034.48837-1-jinpu.wang@ionos.com/T/#t
> v1: https://lore.kernel.org/linux-rdma/20210608103039.39080-1-jinpu.wang@ionos.com/T/#t
> 
> This patchset is based on rdma/for-next branch.

Applied to for-next, thanks

> Note: I tried the patchset for fast memory registration on write path can still apply.
> https://lore.kernel.org/linux-rdma/20210608113536.42965-1-jinpu.wang@ionos.com/T/#t

Not sure how you did this, because it doesn't apply for me, it was
sent from some internal tree by the looks of it.

Jason