mbox series

[for-next,0/4] irdma -next updates

Message ID 20230315145305.955-1-shiraz.saleem@intel.com (mailing list archive)
Headers show
Series irdma -next updates | expand

Message

Shiraz Saleem March 15, 2023, 2:53 p.m. UTC
This series adds a refactor/improvement to the statistics
infrastructure of irdma. And minor updates to IRQ naming,
PBLE function arguments, and removes a redundant call in
irdma_modify_qp_roce.

Krzysztof Czurylo (1):
  RDMA/irdma: Refactor HW statistics

Michal Swiatkowski (1):
  RDMA/irdma: change name of interrupts

Sindhu Devale (1):
  RDMA/irdma: Refactor PBLE functions

Tatyana Nikolova (1):
  RDMA/irdma: Remove a redundant irdma_arp_table() call

 drivers/infiniband/hw/irdma/ctrl.c      | 324 +++++++++++---------------------
 drivers/infiniband/hw/irdma/defs.h      |   9 +-
 drivers/infiniband/hw/irdma/hw.c        |  13 +-
 drivers/infiniband/hw/irdma/i40iw_hw.c  |  60 +++++-
 drivers/infiniband/hw/irdma/icrdma_hw.c |  51 +++++
 drivers/infiniband/hw/irdma/irdma.h     |   1 +
 drivers/infiniband/hw/irdma/main.h      |   3 +
 drivers/infiniband/hw/irdma/pble.c      |  16 +-
 drivers/infiniband/hw/irdma/pble.h      |   2 +-
 drivers/infiniband/hw/irdma/protos.h    |   8 +-
 drivers/infiniband/hw/irdma/type.h      | 166 ++++++----------
 drivers/infiniband/hw/irdma/utils.c     | 172 ++---------------
 drivers/infiniband/hw/irdma/verbs.c     | 200 ++++++++------------
 13 files changed, 406 insertions(+), 619 deletions(-)

Comments

Leon Romanovsky March 19, 2023, 9:37 a.m. UTC | #1
On Wed, 15 Mar 2023 09:53:01 -0500, Shiraz Saleem wrote:
> This series adds a refactor/improvement to the statistics
> infrastructure of irdma. And minor updates to IRQ naming,
> PBLE function arguments, and removes a redundant call in
> irdma_modify_qp_roce.
> 
> Krzysztof Czurylo (1):
>   RDMA/irdma: Refactor HW statistics
> 
> [...]

Applied, thanks!

[1/4] RDMA/irdma: Refactor HW statistics
      https://git.kernel.org/rdma/rdma/c/5a711e580704ac
[2/4] RDMA/irdma: Remove a redundant irdma_arp_table() call
      https://git.kernel.org/rdma/rdma/c/0219ad5d3afbb5
[3/4] RDMA/irdma: change name of interrupts
      https://git.kernel.org/rdma/rdma/c/99f96b4552330d
[4/4] RDMA/irdma: Refactor PBLE functions
      https://git.kernel.org/rdma/rdma/c/cc8997c94bf370

Best regards,