diff mbox series

net/mlx5: DR, Use swap() instead of open coding it

Message ID 20231117071947.112856-1-jiapeng.chong@linux.alibaba.com (mailing list archive)
State Not Applicable
Headers show
Series net/mlx5: DR, Use swap() instead of open coding it | expand

Commit Message

Jiapeng Chong Nov. 17, 2023, 7:19 a.m. UTC
Swap is a function interface that provides exchange function. To avoid
code duplication, we can use swap function.

./drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c:1254:50-51: WARNING opportunity for swap().

Reported-by: Abaci Robot <abaci@linux.alibaba.com>
Closes: https://bugzilla.openanolis.cn/show_bug.cgi?id=7580
Signed-off-by: Jiapeng Chong <jiapeng.chong@linux.alibaba.com>
---
 .../net/ethernet/mellanox/mlx5/core/steering/dr_action.c  | 8 ++------
 1 file changed, 2 insertions(+), 6 deletions(-)

Comments

Przemek Kitszel Nov. 17, 2023, 9:18 a.m. UTC | #1
On 11/17/23 08:19, Jiapeng Chong wrote:
> Swap is a function interface that provides exchange function. To avoid
> code duplication, we can use swap function.
> 
> ./drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c:1254:50-51: WARNING opportunity for swap().
> 
> Reported-by: Abaci Robot <abaci@linux.alibaba.com>
> Closes: https://bugzilla.openanolis.cn/show_bug.cgi?id=7580
> Signed-off-by: Jiapeng Chong <jiapeng.chong@linux.alibaba.com>
> ---
>   .../net/ethernet/mellanox/mlx5/core/steering/dr_action.c  | 8 ++------
>   1 file changed, 2 insertions(+), 6 deletions(-)
> 
> diff --git a/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c b/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c
> index e3ec559369fa..6f9790e97fed 100644
> --- a/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c
> +++ b/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c
> @@ -1170,7 +1170,6 @@ mlx5dr_action_create_mult_dest_tbl(struct mlx5dr_domain *dmn,
>   				   bool ignore_flow_level,
>   				   u32 flow_source)
>   {
> -	struct mlx5dr_cmd_flow_destination_hw_info tmp_hw_dest;
>   	struct mlx5dr_cmd_flow_destination_hw_info *hw_dests;
>   	struct mlx5dr_action **ref_actions;
>   	struct mlx5dr_action *action;
> @@ -1249,11 +1248,8 @@ mlx5dr_action_create_mult_dest_tbl(struct mlx5dr_domain *dmn,
>   	 * one that done in the TX.
>   	 * So, if one of the ft target is wire, put it at the end of the dest list.
>   	 */
> -	if (is_ft_wire && num_dst_ft > 1) {
> -		tmp_hw_dest = hw_dests[last_dest];
> -		hw_dests[last_dest] = hw_dests[num_of_dests - 1];
> -		hw_dests[num_of_dests - 1] = tmp_hw_dest;
> -	}
> +	if (is_ft_wire && num_dst_ft > 1)
> +		swap(hw_dests[last_dest], hw_dests[num_of_dests - 1]);
>   
>   	action = dr_action_create_generic(DR_ACTION_TYP_FT);
>   	if (!action)

Reviewed-by: Przemek Kitszel <przemyslaw.kitszel@intel.com>

For future non-bugfix contributions please target patches to net-next
Saeed Mahameed Dec. 6, 2023, 10:37 p.m. UTC | #2
On 17 Nov 15:19, Jiapeng Chong wrote:
>Swap is a function interface that provides exchange function. To avoid
>code duplication, we can use swap function.
>
>./drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c:1254:50-51: WARNING opportunity for swap().
>
>Reported-by: Abaci Robot <abaci@linux.alibaba.com>
>Closes: https://bugzilla.openanolis.cn/show_bug.cgi?id=7580
>Signed-off-by: Jiapeng Chong <jiapeng.chong@linux.alibaba.com>
>---

applied to net-next-mlx5
-Saeed.
diff mbox series

Patch

diff --git a/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c b/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c
index e3ec559369fa..6f9790e97fed 100644
--- a/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c
+++ b/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c
@@ -1170,7 +1170,6 @@  mlx5dr_action_create_mult_dest_tbl(struct mlx5dr_domain *dmn,
 				   bool ignore_flow_level,
 				   u32 flow_source)
 {
-	struct mlx5dr_cmd_flow_destination_hw_info tmp_hw_dest;
 	struct mlx5dr_cmd_flow_destination_hw_info *hw_dests;
 	struct mlx5dr_action **ref_actions;
 	struct mlx5dr_action *action;
@@ -1249,11 +1248,8 @@  mlx5dr_action_create_mult_dest_tbl(struct mlx5dr_domain *dmn,
 	 * one that done in the TX.
 	 * So, if one of the ft target is wire, put it at the end of the dest list.
 	 */
-	if (is_ft_wire && num_dst_ft > 1) {
-		tmp_hw_dest = hw_dests[last_dest];
-		hw_dests[last_dest] = hw_dests[num_of_dests - 1];
-		hw_dests[num_of_dests - 1] = tmp_hw_dest;
-	}
+	if (is_ft_wire && num_dst_ft > 1)
+		swap(hw_dests[last_dest], hw_dests[num_of_dests - 1]);
 
 	action = dr_action_create_generic(DR_ACTION_TYP_FT);
 	if (!action)