diff mbox series

ARM: dts: arm,integrator-ap: Fix PCI node name

Message ID 20230830200437.715735-1-robh@kernel.org (mailing list archive)
State Mainlined
Headers show
Series ARM: dts: arm,integrator-ap: Fix PCI node name | expand

Commit Message

Rob Herring (Arm) Aug. 30, 2023, 8:04 p.m. UTC
PCI bus nodes should be named "pci":

arch/arm/boot/dts/arm/integratorap.dts:161.22-206.4: Warning (pci_bridge): /pciv3@62000000: node name is not "pci" or "pcie"

Signed-off-by: Rob Herring <robh@kernel.org>
---
 arch/arm/boot/dts/arm/integratorap.dts | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Linus Walleij Sept. 12, 2023, 7:21 a.m. UTC | #1
On Wed, Aug 30, 2023 at 10:05 PM Rob Herring <robh@kernel.org> wrote:

> PCI bus nodes should be named "pci":
>
> arch/arm/boot/dts/arm/integratorap.dts:161.22-206.4: Warning (pci_bridge): /pciv3@62000000: node name is not "pci" or "pcie"
>
> Signed-off-by: Rob Herring <robh@kernel.org>

This was fixed during the merge window by Lin Yujun.
Thanks anyway!

Yours,
Linus Walleij
diff mbox series

Patch

diff --git a/arch/arm/boot/dts/arm/integratorap.dts b/arch/arm/boot/dts/arm/integratorap.dts
index 5b52d75bc6be..d9927d3181dc 100644
--- a/arch/arm/boot/dts/arm/integratorap.dts
+++ b/arch/arm/boot/dts/arm/integratorap.dts
@@ -158,7 +158,7 @@  pic: pic@14000000 {
 		valid-mask = <0x003fffff>;
 	};
 
-	pci: pciv3@62000000 {
+	pci: pci@62000000 {
 		compatible = "arm,integrator-ap-pci", "v3,v360epc-pci";
 		device_type = "pci";
 		#interrupt-cells = <1>;