Message ID | 1425290054-26631-2-git-send-email-hofrat@osadl.org (mailing list archive) |
---|---|
State | Accepted |
Delegated to: | Johannes Berg |
Headers | show |
diff --git a/net/mac80211/mesh_plink.c b/net/mac80211/mesh_plink.c index 4eefd5d..8465c05 100644 --- a/net/mac80211/mesh_plink.c +++ b/net/mac80211/mesh_plink.c @@ -621,7 +621,7 @@ static void mesh_plink_timer(unsigned long data) sta->llid, sta->plid, reason); } -static inline void mesh_plink_timer_set(struct sta_info *sta, int timeout) +static inline void mesh_plink_timer_set(struct sta_info *sta, u32 timeout) { sta->plink_timer.expires = jiffies + msecs_to_jiffies(timeout); sta->plink_timer.data = (unsigned long) sta;
timeout was being passed as int but assigned from u32/u16 values and used as unsigned type. This is really only for better readability. Signed-off-by: Nicholas Mc Guire <hofrat@osadl.org> --- After review of the use locations of mesh_plink_timer_set() and declarations in sta_info.h this should not be breaking any integer promotions. This patch applies on top of "[PATCH 1/2] mesh_plink: use msecs_to_jiffies for proper time conversion" Patch was only compile tested with x86_64_defconfig + CONFIG_MAC80211_MESH=y Patch is against 4.0-rc1 (localversion-next is -next-20150302) net/mac80211/mesh_plink.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)