diff mbox

[crda,1/4] do not run ldconfig

Message ID 1425498714-8654-1-git-send-email-vapier@gentoo.org (mailing list archive)
State Not Applicable
Delegated to: Kalle Valo
Headers show

Commit Message

Mike Frysinger March 4, 2015, 7:51 p.m. UTC
From: Mike Frysinger <vapier@chromium.org>

Let the distro/user deal with ldconfig updating.  Running it blindly like
this breaks DESTDIR installs as `ldconfig` only operates on system paths.

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
---
 Makefile | 1 -
 1 file changed, 1 deletion(-)
diff mbox

Patch

diff --git a/Makefile b/Makefile
index a3ead30..46c683d 100644
--- a/Makefile
+++ b/Makefile
@@ -127,7 +127,6 @@  install-libreg:
 	$(NQ) '  INSTALL  libreg'
 	$(Q)mkdir -p $(DESTDIR)/$(LIBDIR)
 	$(Q)cp $(LIBREG) $(DESTDIR)/$(LIBDIR)/
-	$(Q)ldconfig
 
 %.o: %.c regdb.h $(LIBREG)
 	$(NQ) '  CC  ' $@