diff mbox

[crda,4/4] clean up CFLAGS handling

Message ID 1425498714-8654-4-git-send-email-vapier@gentoo.org (mailing list archive)
State Not Applicable
Delegated to: Kalle Valo
Headers show

Commit Message

Mike Frysinger March 4, 2015, 7:51 p.m. UTC
From: Mike Frysinger <vapier@chromium.org>

Rather than append -O2 -g all the time to the user's CFLAGS (and thus
clobbering whatever they have set up), initialize the default value to
that and let the user override it entirely.

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
---
 Makefile | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox

Patch

diff --git a/Makefile b/Makefile
index 5f988f4..8e345a1 100644
--- a/Makefile
+++ b/Makefile
@@ -26,9 +26,9 @@  PUBKEY_DIR?=pubkeys
 RUNTIME_PUBKEY_DIR?=/etc/wireless-regdb/pubkeys
 
 WERROR = -Werror
-CFLAGS += -O2 -fpic
+CFLAGS ?= -O2 -g
+CFLAGS += -fpic
 CFLAGS += -std=gnu99 -Wall $(WERROR) -pedantic
-CFLAGS += -Wall -g
 LDLIBREG += -lreg
 LDLIBS += $(LDLIBREG)
 LDLIBS += -lm