diff mbox

[crda] libreg: link against crypto libs

Message ID 1425785565-26601-1-git-send-email-vapier@gentoo.org (mailing list archive)
State Not Applicable
Delegated to: Kalle Valo
Headers show

Commit Message

Mike Frysinger March 8, 2015, 3:32 a.m. UTC
Since libreg uses funcs from the crypto lib, make sure we link them.

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
---
 Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox

Patch

diff --git a/Makefile b/Makefile
index 8e345a1..77708e6 100644
--- a/Makefile
+++ b/Makefile
@@ -117,7 +117,7 @@  keys-%.c: utils/key2pub.py $(wildcard $(PUBKEY_DIR)/*.pem)
 
 $(LIBREG): regdb.h reglib.h reglib.c
 	$(NQ) '  CC  ' $@
-	$(Q)$(CC) $(CFLAGS) $(CPPFLAGS) -o $@ -shared -Wl,-soname,$(LIBREG) $^
+	$(Q)$(CC) $(CFLAGS) $(CPPFLAGS) -o $@ -shared -Wl,-soname,$(LIBREG) $^ $(LDLIBS)
 
 install-libreg-headers:
 	$(NQ) '  INSTALL  libreg-headers'