diff mbox

[crda,v2] libreg: link against crypto libs

Message ID 1425939126-12478-1-git-send-email-vapier@gentoo.org (mailing list archive)
State Not Applicable
Delegated to: Kalle Valo
Headers show

Commit Message

Mike Frysinger March 9, 2015, 10:12 p.m. UTC
Since libreg uses funcs from the crypto lib, make sure we link them.

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
---
v2
	- the current LDLIBS mess includes -lreg in there which we have to strip

 Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox

Patch

diff --git a/Makefile b/Makefile
index 8e345a1..5ba1664 100644
--- a/Makefile
+++ b/Makefile
@@ -117,7 +117,7 @@  keys-%.c: utils/key2pub.py $(wildcard $(PUBKEY_DIR)/*.pem)
 
 $(LIBREG): regdb.h reglib.h reglib.c
 	$(NQ) '  CC  ' $@
-	$(Q)$(CC) $(CFLAGS) $(CPPFLAGS) -o $@ -shared -Wl,-soname,$(LIBREG) $^
+	$(Q)$(CC) $(CFLAGS) $(CPPFLAGS) -o $@ -shared -Wl,-soname,$(LIBREG) $^ $(filter-out -lreg,$(LDLIBS))
 
 install-libreg-headers:
 	$(NQ) '  INSTALL  libreg-headers'