Message ID | 1469963924-8800-1-git-send-email-arvind.yadav.cs@gmail.com (mailing list archive) |
---|---|
State | Not Applicable |
Delegated to: | Kalle Valo |
Headers | show |
On 08/01/2016 02:02 AM, Arnd Bergmann wrote: > On Sunday, July 31, 2016 4:48:44 PM CEST Arvind Yadav wrote: >> IS_ERR_VALUE() assumes that parameter is an unsigned long. >> It can not be used to check if 'unsigned int' is passed insted. >> Which tends to reflect an error. >> >> In 64bit architectures sizeof (int) == 4 && sizeof (long) == 8. >> IS_ERR_VALUE(x) is ((x) >= (unsigned long)-4095). >> >> IS_ERR_VALUE() of 'unsigned int' is always false because the 32bit >> value is zero extended to 64 bits. >> >> Value of (unsigned int)-4095 is always less than value of >> (unsigned long)-4095. >> >> Now We are taking only first 32 bit for error checking rest of the 32 bit >> we ignore such that we get appropriate comparison on 64bit system as well. > > This is completely wrong: if you have a valid 64-bit pointer like > 0x00001234ffffff00, this will be interpreted as an error now. > >> First 32bit of Value of (unsigned int)-4095 and (unsigned long)-4095 will >> be equal. >> >> Signed-off-by: Arvind Yadav <arvind.yadav.cs@gmail.com> >> --- >> include/linux/err.h | 12 +++++++++++- >> 1 file changed, 11 insertions(+), 1 deletion(-) >> >> diff --git a/include/linux/err.h b/include/linux/err.h >> index 1e35588..c2a2789 100644 >> --- a/include/linux/err.h >> +++ b/include/linux/err.h >> @@ -18,7 +18,17 @@ >> >> #ifndef __ASSEMBLY__ >> >> -#define IS_ERR_VALUE(x) unlikely((unsigned long)(void *)(x) >= (unsigned long)-MAX_ERRNO) >> +#define IS_ERR_VALUE(x) unlikely(is_error_check(x)) >> + >> +static inline int is_error_check(unsigned long error) > > Please leave the existing macro alone. I think you were looking for > something specific to the return code of qe_muram_alloc() function, > so please add a helper in that subsystem if you need it, not in > the generic header files. qe_muram_alloc (a.k.a. cpm_muram_alloc) returns unsigned long. The problem is certain callers that store the return value in a u32. Why not just fix those callers to store it in unsigned long (at least until error checking is done)? -Scott -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On Monday, August 1, 2016 4:55:43 PM CEST Scott Wood wrote: > On 08/01/2016 02:02 AM, Arnd Bergmann wrote: > >> diff --git a/include/linux/err.h b/include/linux/err.h > >> index 1e35588..c2a2789 100644 > >> --- a/include/linux/err.h > >> +++ b/include/linux/err.h > >> @@ -18,7 +18,17 @@ > >> > >> #ifndef __ASSEMBLY__ > >> > >> -#define IS_ERR_VALUE(x) unlikely((unsigned long)(void *)(x) >= (unsigned long)-MAX_ERRNO) > >> +#define IS_ERR_VALUE(x) unlikely(is_error_check(x)) > >> + > >> +static inline int is_error_check(unsigned long error) > > > > Please leave the existing macro alone. I think you were looking for > > something specific to the return code of qe_muram_alloc() function, > > so please add a helper in that subsystem if you need it, not in > > the generic header files. > > qe_muram_alloc (a.k.a. cpm_muram_alloc) returns unsigned long. The > problem is certain callers that store the return value in a u32. Why > not just fix those callers to store it in unsigned long (at least until > error checking is done)? > Yes, that would also address another problem with code like kfree((void *)ugeth->tx_bd_ring_offset[i]); which is not 64-bit safe when tx_bd_ring_offset is a 32-bit value that also holds the return value of qe_muram_alloc. Arnd -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On Tuesday 02 August 2016 01:15 PM, Arnd Bergmann wrote: > On Monday, August 1, 2016 4:55:43 PM CEST Scott Wood wrote: >> On 08/01/2016 02:02 AM, Arnd Bergmann wrote: >>>> diff --git a/include/linux/err.h b/include/linux/err.h >>>> index 1e35588..c2a2789 100644 >>>> --- a/include/linux/err.h >>>> +++ b/include/linux/err.h >>>> @@ -18,7 +18,17 @@ >>>> >>>> #ifndef __ASSEMBLY__ >>>> >>>> -#define IS_ERR_VALUE(x) unlikely((unsigned long)(void *)(x) >= (unsigned long)-MAX_ERRNO) >>>> +#define IS_ERR_VALUE(x) unlikely(is_error_check(x)) >>>> + >>>> +static inline int is_error_check(unsigned long error) >>> Please leave the existing macro alone. I think you were looking for >>> something specific to the return code of qe_muram_alloc() function, >>> so please add a helper in that subsystem if you need it, not in >>> the generic header files. >> qe_muram_alloc (a.k.a. cpm_muram_alloc) returns unsigned long. The >> problem is certain callers that store the return value in a u32. Why >> not just fix those callers to store it in unsigned long (at least until >> error checking is done)? >> > Yes, that would also address another problem with code like > > kfree((void *)ugeth->tx_bd_ring_offset[i]); > > which is not 64-bit safe when tx_bd_ring_offset is a 32-bit value > that also holds the return value of qe_muram_alloc. > > Arnd Yes, we will fix caller. Caller api is not safe on 64bit. Even qe_muram_addr(a.k.a. cpm_muram_addr )passing value unsigned int, but it should be unsigned long. Need to work on it. Arvind -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On 08/02/2016 10:34 AM, arvind Yadav wrote: > > > On Tuesday 02 August 2016 01:15 PM, Arnd Bergmann wrote: >> On Monday, August 1, 2016 4:55:43 PM CEST Scott Wood wrote: >>> On 08/01/2016 02:02 AM, Arnd Bergmann wrote: >>>>> diff --git a/include/linux/err.h b/include/linux/err.h >>>>> index 1e35588..c2a2789 100644 >>>>> --- a/include/linux/err.h >>>>> +++ b/include/linux/err.h >>>>> @@ -18,7 +18,17 @@ >>>>> >>>>> #ifndef __ASSEMBLY__ >>>>> >>>>> -#define IS_ERR_VALUE(x) unlikely((unsigned long)(void *)(x) >= (unsigned long)-MAX_ERRNO) >>>>> +#define IS_ERR_VALUE(x) unlikely(is_error_check(x)) >>>>> + >>>>> +static inline int is_error_check(unsigned long error) >>>> Please leave the existing macro alone. I think you were looking for >>>> something specific to the return code of qe_muram_alloc() function, >>>> so please add a helper in that subsystem if you need it, not in >>>> the generic header files. >>> qe_muram_alloc (a.k.a. cpm_muram_alloc) returns unsigned long. The >>> problem is certain callers that store the return value in a u32. Why >>> not just fix those callers to store it in unsigned long (at least until >>> error checking is done)? >>> >> Yes, that would also address another problem with code like >> >> kfree((void *)ugeth->tx_bd_ring_offset[i]); >> >> which is not 64-bit safe when tx_bd_ring_offset is a 32-bit value >> that also holds the return value of qe_muram_alloc. Well, hopefully it doesn't hold a return of qe_muram_alloc() when it's being passed to kfree()... There's also the code that casts kmalloc()'s return to u32, etc. ucc_geth is not 64-bit clean in general. >> >> Arnd > Yes, we will fix caller. Caller api is not safe on 64bit. The API is fine (or at least, I haven't seen a valid issue pointed out yet). The problem is the ucc_geth driver. > Even qe_muram_addr(a.k.a. cpm_muram_addr )passing value unsigned int, > but it should be unsigned long. cpm_muram_addr takes unsigned long as a parameter, not that it matters since you can't pass errors into it and a muram offset should never exceed 32 bits. -Scott -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On Wednesday 03 August 2016 01:27 AM, Scott Wood wrote: > On 08/02/2016 10:34 AM, arvind Yadav wrote: >> >> On Tuesday 02 August 2016 01:15 PM, Arnd Bergmann wrote: >>> On Monday, August 1, 2016 4:55:43 PM CEST Scott Wood wrote: >>>> On 08/01/2016 02:02 AM, Arnd Bergmann wrote: >>>>>> diff --git a/include/linux/err.h b/include/linux/err.h >>>>>> index 1e35588..c2a2789 100644 >>>>>> --- a/include/linux/err.h >>>>>> +++ b/include/linux/err.h >>>>>> @@ -18,7 +18,17 @@ >>>>>> >>>>>> #ifndef __ASSEMBLY__ >>>>>> >>>>>> -#define IS_ERR_VALUE(x) unlikely((unsigned long)(void *)(x) >= (unsigned long)-MAX_ERRNO) >>>>>> +#define IS_ERR_VALUE(x) unlikely(is_error_check(x)) >>>>>> + >>>>>> +static inline int is_error_check(unsigned long error) >>>>> Please leave the existing macro alone. I think you were looking for >>>>> something specific to the return code of qe_muram_alloc() function, >>>>> so please add a helper in that subsystem if you need it, not in >>>>> the generic header files. >>>> qe_muram_alloc (a.k.a. cpm_muram_alloc) returns unsigned long. The >>>> problem is certain callers that store the return value in a u32. Why >>>> not just fix those callers to store it in unsigned long (at least until >>>> error checking is done)? >>>> >>> Yes, that would also address another problem with code like >>> >>> kfree((void *)ugeth->tx_bd_ring_offset[i]); >>> >>> which is not 64-bit safe when tx_bd_ring_offset is a 32-bit value >>> that also holds the return value of qe_muram_alloc. > Well, hopefully it doesn't hold a return of qe_muram_alloc() when it's > being passed to kfree()... > > There's also the code that casts kmalloc()'s return to u32, etc. > ucc_geth is not 64-bit clean in general. > >>> Arnd >> Yes, we will fix caller. Caller api is not safe on 64bit. > The API is fine (or at least, I haven't seen a valid issue pointed out > yet). The problem is the ucc_geth driver. > >> Even qe_muram_addr(a.k.a. cpm_muram_addr )passing value unsigned int, >> but it should be unsigned long. > cpm_muram_addr takes unsigned long as a parameter, not that it matters > since you can't pass errors into it and a muram offset should never > exceed 32 bits. > > -Scott Yes, It will work for 32bit machine. But will not safe for 64bit. Example : ugeth->tx_bd_ring_offset[j] = qe_muram_alloc(length UCC_GETH_TX_BD_RING_ALIGNMENT); if (!IS_ERR_VALUE(ugeth->tx_bd_ring_offset[j])) ugeth->p_tx_bd_ring[j] = (u8 __iomem *) qe_muram_addr(ugeth-> tx_bd_ring_offset[j]); If qe_muram_alloc will return any error, IS_ERR_VALUE will always return 0 (IS_ERR_VALUE will always pass for 'unsigned int'). Now qe_muram_addr will return wrong virtual address. Which can cause an error. -Arvind -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/include/linux/err.h b/include/linux/err.h index 1e35588..c2a2789 100644 --- a/include/linux/err.h +++ b/include/linux/err.h @@ -18,7 +18,17 @@ #ifndef __ASSEMBLY__ -#define IS_ERR_VALUE(x) unlikely((unsigned long)(void *)(x) >= (unsigned long)-MAX_ERRNO) +#define IS_ERR_VALUE(x) unlikely(is_error_check(x)) + +static inline int is_error_check(unsigned long error) +{ + unsigned int first32bit = (error & 0xFFFFFFFF); + + if (first32bit >= (unsigned int)-MAX_ERRNO) + return 1; + else + return 0; +} static inline void * __must_check ERR_PTR(long error) {
IS_ERR_VALUE() assumes that parameter is an unsigned long. It can not be used to check if 'unsigned int' is passed insted. Which tends to reflect an error. In 64bit architectures sizeof (int) == 4 && sizeof (long) == 8. IS_ERR_VALUE(x) is ((x) >= (unsigned long)-4095). IS_ERR_VALUE() of 'unsigned int' is always false because the 32bit value is zero extended to 64 bits. Value of (unsigned int)-4095 is always less than value of (unsigned long)-4095. Now We are taking only first 32 bit for error checking rest of the 32 bit we ignore such that we get appropriate comparison on 64bit system as well. First 32bit of Value of (unsigned int)-4095 and (unsigned long)-4095 will be equal. Signed-off-by: Arvind Yadav <arvind.yadav.cs@gmail.com> --- include/linux/err.h | 12 +++++++++++- 1 file changed, 11 insertions(+), 1 deletion(-)