diff mbox

[7/8] staging: wilc1000: fix line over 80 char in wilc_wlan_cfg_set()

Message ID 1519662722-15761-8-git-send-email-ajay.kathat@microchip.com (mailing list archive)
State Not Applicable
Delegated to: Kalle Valo
Headers show

Commit Message

Ajay Singh Feb. 26, 2018, 4:32 p.m. UTC
Fix 'line over 80 character' issue found by checkpatch.pl script.

Signed-off-by: Ajay Singh <ajay.kathat@microchip.com>
---
 drivers/staging/wilc1000/wilc_wlan.c | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Dan Carpenter Feb. 27, 2018, 9:36 a.m. UTC | #1
On Mon, Feb 26, 2018 at 10:02:01PM +0530, Ajay Singh wrote:
> Fix 'line over 80 character' issue found by checkpatch.pl script.
> 
> Signed-off-by: Ajay Singh <ajay.kathat@microchip.com>
> ---
>  drivers/staging/wilc1000/wilc_wlan.c | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/staging/wilc1000/wilc_wlan.c b/drivers/staging/wilc1000/wilc_wlan.c
> index 223bf8b..acf7591 100644
> --- a/drivers/staging/wilc1000/wilc_wlan.c
> +++ b/drivers/staging/wilc1000/wilc_wlan.c
> @@ -1230,6 +1230,8 @@ int wilc_wlan_cfg_set(struct wilc_vif *vif, int start, u16 wid, u8 *buffer,
>  	wilc->cfg_frame_offset = offset;
>  
>  	if (commit) {
> +		unsigned long tmp = msecs_to_jiffies(CFG_PKTS_TIMEOUT);

Again.  This "tmp" is a bad name here.  "tmp" can be a good name, and
I use it all the time, but *here* it is a bad name.

regards,
dan carpenter
Dan Carpenter Feb. 27, 2018, 9:50 a.m. UTC | #2
On Mon, Feb 26, 2018 at 10:02:01PM +0530, Ajay Singh wrote:
> Fix 'line over 80 character' issue found by checkpatch.pl script.
> 
> Signed-off-by: Ajay Singh <ajay.kathat@microchip.com>
> ---
>  drivers/staging/wilc1000/wilc_wlan.c | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/staging/wilc1000/wilc_wlan.c b/drivers/staging/wilc1000/wilc_wlan.c
> index 223bf8b..acf7591 100644
> --- a/drivers/staging/wilc1000/wilc_wlan.c
> +++ b/drivers/staging/wilc1000/wilc_wlan.c
> @@ -1230,6 +1230,8 @@ int wilc_wlan_cfg_set(struct wilc_vif *vif, int start, u16 wid, u8 *buffer,
>  	wilc->cfg_frame_offset = offset;
>  
>  	if (commit) {
> +		unsigned long tmp = msecs_to_jiffies(CFG_PKTS_TIMEOUT);
> +
>  		netdev_dbg(vif->ndev,
>  			   "[WILC]PACKET Commit with sequence number %d\n",
>  			   wilc->cfg_seq_no);
> @@ -1239,8 +1241,7 @@ int wilc_wlan_cfg_set(struct wilc_vif *vif, int start, u16 wid, u8 *buffer,
>  		if (wilc_wlan_cfg_commit(vif, WILC_CFG_SET, drv_handler))
>  			ret_size = 0;
>  
> -		if (!wait_for_completion_timeout(&wilc->cfg_event,
> -						 msecs_to_jiffies(CFG_PKTS_TIMEOUT))) {
> +		if (!wait_for_completion_timeout(&wilc->cfg_event, tmp)) {


Also, it's not just the variable name I have an issue with.  I like that
I can see CFG_PKTS_TIMEOUT directly instead of having to look for it a
few lines back.  Don't add unecessary indirection.

So just leave this one as-is.  Or flip the "if (commit) " condition
around and do:

	if (!commit)
		return ret_size;

regards,
dan carpenter
diff mbox

Patch

diff --git a/drivers/staging/wilc1000/wilc_wlan.c b/drivers/staging/wilc1000/wilc_wlan.c
index 223bf8b..acf7591 100644
--- a/drivers/staging/wilc1000/wilc_wlan.c
+++ b/drivers/staging/wilc1000/wilc_wlan.c
@@ -1230,6 +1230,8 @@  int wilc_wlan_cfg_set(struct wilc_vif *vif, int start, u16 wid, u8 *buffer,
 	wilc->cfg_frame_offset = offset;
 
 	if (commit) {
+		unsigned long tmp = msecs_to_jiffies(CFG_PKTS_TIMEOUT);
+
 		netdev_dbg(vif->ndev,
 			   "[WILC]PACKET Commit with sequence number %d\n",
 			   wilc->cfg_seq_no);
@@ -1239,8 +1241,7 @@  int wilc_wlan_cfg_set(struct wilc_vif *vif, int start, u16 wid, u8 *buffer,
 		if (wilc_wlan_cfg_commit(vif, WILC_CFG_SET, drv_handler))
 			ret_size = 0;
 
-		if (!wait_for_completion_timeout(&wilc->cfg_event,
-						 msecs_to_jiffies(CFG_PKTS_TIMEOUT))) {
+		if (!wait_for_completion_timeout(&wilc->cfg_event, tmp)) {
 			netdev_dbg(vif->ndev, "Set Timed Out\n");
 			ret_size = 0;
 		}