Message ID | 20160709232834.31654-4-martin.blumenstingl@googlemail.com (mailing list archive) |
---|---|
State | Changes Requested |
Delegated to: | Kalle Valo |
Headers | show |
Martin Blumenstingl <martin.blumenstingl@googlemail.com> writes: > + if (of_property_read_bool(np, "qca,clk-25mhz")) > + ah->is_clk_25mhz = true; > + > + if (of_property_read_bool(np, "qca,disable-2ghz")) > + ah->disable_2ghz = true; > + > + if (of_property_read_bool(np, "qca,disable-5ghz")) > + ah->disable_5ghz = true; This is bike-shedding, but how about ah->is_clk_25mhz = of_property_read_bool(np, "qca,clk-25mhz"); ah->disable_2ghz = of_property_read_bool(np, "qca,disable-2ghz"); ah->disable_5ghz = of_property_read_bool(np, "qca,disable-5ghz"); instead? Bjørn -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
Am 10.07.2016 um 02:19 schrieb Bjørn Mork: > Martin Blumenstingl <martin.blumenstingl@googlemail.com> writes: > >> + if (of_property_read_bool(np, "qca,clk-25mhz")) >> + ah->is_clk_25mhz = true; >> + >> + if (of_property_read_bool(np, "qca,disable-2ghz")) >> + ah->disable_2ghz = true; >> + >> + if (of_property_read_bool(np, "qca,disable-5ghz")) >> + ah->disable_5ghz = true; > > This is bike-shedding, but how about > > ah->is_clk_25mhz = of_property_read_bool(np, "qca,clk-25mhz"); > ah->disable_2ghz = of_property_read_bool(np, "qca,disable-2ghz"); > ah->disable_5ghz = of_property_read_bool(np, "qca,disable-5ghz"); > > instead? Hm... i assume each WiFi hw in the world can reuse this settings, may be it i worth to use generic names?
On Sun, Jul 10, 2016 at 2:19 AM, Bjørn Mork <bjorn@mork.no> wrote: > Martin Blumenstingl <martin.blumenstingl@googlemail.com> writes: > >> + if (of_property_read_bool(np, "qca,clk-25mhz")) >> + ah->is_clk_25mhz = true; >> + >> + if (of_property_read_bool(np, "qca,disable-2ghz")) >> + ah->disable_2ghz = true; >> + >> + if (of_property_read_bool(np, "qca,disable-5ghz")) >> + ah->disable_5ghz = true; > > This is bike-shedding, but how about > > ah->is_clk_25mhz = of_property_read_bool(np, "qca,clk-25mhz"); > ah->disable_2ghz = of_property_read_bool(np, "qca,disable-2ghz"); > ah->disable_5ghz = of_property_read_bool(np, "qca,disable-5ghz"); I'm fine with either way - I'll simply adhere to the coding style that the ath9k devs want to use, so just let me know which one you prefer. -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/drivers/net/wireless/ath/ath9k/init.c b/drivers/net/wireless/ath/ath9k/init.c index edc74fc..9dd7ed5 100644 --- a/drivers/net/wireless/ath/ath9k/init.c +++ b/drivers/net/wireless/ath/ath9k/init.c @@ -20,6 +20,8 @@ #include <linux/slab.h> #include <linux/ath9k_platform.h> #include <linux/module.h> +#include <linux/of.h> +#include <linux/of_net.h> #include <linux/relay.h> #include <net/ieee80211_radiotap.h> @@ -555,6 +557,55 @@ static int ath9k_init_platform(struct ath_softc *sc) return 0; } +static int ath9k_of_init(struct ath_softc *sc) +{ + struct device_node *np = sc->dev->of_node; + struct ath_hw *ah = sc->sc_ah; + struct ath_common *common = ath9k_hw_common(ah); + enum ath_bus_type bus_type = common->bus_ops->ath_bus_type; + const char *mac; + char eeprom_name[100]; + int ret; + + if (!of_device_is_available(np)) + return 0; + + ath_dbg(common, CONFIG, "parsing configuration from OF node\n"); + + if (of_property_read_bool(np, "qca,clk-25mhz")) + ah->is_clk_25mhz = true; + + if (of_property_read_bool(np, "qca,disable-2ghz")) + ah->disable_2ghz = true; + + if (of_property_read_bool(np, "qca,disable-5ghz")) + ah->disable_5ghz = true; + + if (of_property_read_bool(np, "qca,check-eeprom-endianness")) + ah->ah_flags &= ~AH_NO_EEP_SWAP; + else + ah->ah_flags |= AH_NO_EEP_SWAP; + + if (of_property_read_bool(np, "qca,no-eeprom")) { + /* ath9k-eeprom-<bus>-<id>.bin */ + scnprintf(eeprom_name, sizeof(eeprom_name), + "ath9k-eeprom-%s-%s.bin", + ath_bus_type_to_string(bus_type), dev_name(ah->dev)); + + ret = ath9k_eeprom_request(sc, eeprom_name); + if (ret) + return ret; + } + + mac = of_get_mac_address(np); + if (mac) + ether_addr_copy(common->macaddr, mac); + + ah->ah_flags &= ~AH_USE_EEPROM; + + return 0; +} + static int ath9k_init_softc(u16 devid, struct ath_softc *sc, const struct ath_bus_ops *bus_ops) { @@ -611,6 +662,10 @@ static int ath9k_init_softc(u16 devid, struct ath_softc *sc, if (ret) return ret; + ret = ath9k_of_init(sc); + if (ret) + return ret; + if (ath9k_led_active_high != -1) ah->config.led_active_high = ath9k_led_active_high == 1;
This makes it possible to configure ath9k based devices using devicetree. That makes some out-of-tree "convert devicetree to ath9k_platform_data glue"-code obsolete. Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com> --- drivers/net/wireless/ath/ath9k/init.c | 55 +++++++++++++++++++++++++++++++++++ 1 file changed, 55 insertions(+)