Message ID | 20171103201425.GA26452@embeddedor.com (mailing list archive) |
---|---|
State | Accepted |
Commit | 626ab6707abe6cccc0cb26454d13b0efd72b8a6c |
Delegated to: | Kalle Valo |
Headers | show |
"Gustavo A. R. Silva" <garsilva@embeddedor.com> wrote: > Make use of the swap macro and remove unnecessary variable temp. > This makes the code easier to read and maintain. > > This code was detected with the help of Coccinelle. > > Signed-off-by: Gustavo A. R. Silva <garsilva@embeddedor.com> > Signed-off-by: Kalle Valo <kvalo@qca.qualcomm.com> Patch applied to ath-next branch of ath.git, thanks. 626ab6707abe ath9k: dfs: use swap macro in ath9k_check_chirping
diff --git a/drivers/net/wireless/ath/ath9k/dfs.c b/drivers/net/wireless/ath/ath9k/dfs.c index 40a397f..6fee9a4 100644 --- a/drivers/net/wireless/ath/ath9k/dfs.c +++ b/drivers/net/wireless/ath/ath9k/dfs.c @@ -123,11 +123,9 @@ static bool ath9k_check_chirping(struct ath_softc *sc, u8 *data, fft = (struct ath9k_dfs_fft_40 *) (data + 2); ath_dbg(common, DFS, "fixing datalen by 2\n"); } - if (IS_CHAN_HT40MINUS(ah->curchan)) { - int temp = is_ctl; - is_ctl = is_ext; - is_ext = temp; - } + if (IS_CHAN_HT40MINUS(ah->curchan)) + swap(is_ctl, is_ext); + for (i = 0; i < FFT_NUM_SAMPLES; i++) max_bin[i] = ath9k_get_max_index_ht40(fft + i, is_ctl, is_ext);
Make use of the swap macro and remove unnecessary variable temp. This makes the code easier to read and maintain. This code was detected with the help of Coccinelle. Signed-off-by: Gustavo A. R. Silva <garsilva@embeddedor.com> --- drivers/net/wireless/ath/ath9k/dfs.c | 8 +++----- 1 file changed, 3 insertions(+), 5 deletions(-)