Message ID | 20190403185905.GA8650@embeddedor (mailing list archive) |
---|---|
State | Accepted |
Commit | 0c7beb2db9a5aa7aae31725c25226c526aea3660 |
Delegated to: | Kalle Valo |
Headers | show |
Series | [next] zd1211rw: use struct_size() helper | expand |
"Gustavo A. R. Silva" <gustavo@embeddedor.com> wrote: > Make use of the struct_size() helper instead of an open-coded version > in order to avoid any potential type mistakes, in particular in the > context in which this code is being used. > > So, replace code of the following form: > > sizeof(struct usb_req_write_regs) + count * sizeof(struct reg_data) > > with: > > struct_size(req, reg_writes, count) > > This code was detected with the help of Coccinelle. > > Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com> Patch applied to wireless-drivers-next.git, thanks. 0c7beb2db9a5 zd1211rw: use struct_size() helper
diff --git a/drivers/net/wireless/zydas/zd1211rw/zd_usb.c b/drivers/net/wireless/zydas/zd1211rw/zd_usb.c index c2cda3acd4af..a094d5b3383c 100644 --- a/drivers/net/wireless/zydas/zd1211rw/zd_usb.c +++ b/drivers/net/wireless/zydas/zd1211rw/zd_usb.c @@ -1917,8 +1917,7 @@ int zd_usb_iowrite16v_async(struct zd_usb *usb, const struct zd_ioreq16 *ioreqs, if (!urb) return -ENOMEM; - req_len = sizeof(struct usb_req_write_regs) + - count * sizeof(struct reg_data); + req_len = struct_size(req, reg_writes, count); req = kmalloc(req_len, GFP_KERNEL); if (!req) { r = -ENOMEM;
Make use of the struct_size() helper instead of an open-coded version in order to avoid any potential type mistakes, in particular in the context in which this code is being used. So, replace code of the following form: sizeof(struct usb_req_write_regs) + count * sizeof(struct reg_data) with: struct_size(req, reg_writes, count) This code was detected with the help of Coccinelle. Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com> --- drivers/net/wireless/zydas/zd1211rw/zd_usb.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-)