diff mbox series

[-next] wifi: wfx: Use devm_kmemdup to replace devm_kmalloc + memcpy

Message ID 20230810114939.2104013-1-lizetao1@huawei.com (mailing list archive)
State Accepted
Commit eaa8023e9bb30926b154af72be0cadbebfc8e878
Delegated to: Kalle Valo
Headers show
Series [-next] wifi: wfx: Use devm_kmemdup to replace devm_kmalloc + memcpy | expand

Commit Message

Li Zetao Aug. 10, 2023, 11:49 a.m. UTC
Use the helper function devm_kmemdup() rather than duplicating its
implementation, which helps to enhance code readability.

Signed-off-by: Li Zetao <lizetao1@huawei.com>
---
 drivers/net/wireless/silabs/wfx/main.c | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

Comments

Jérôme Pouiller Aug. 10, 2023, 12:44 p.m. UTC | #1
On Thursday 10 August 2023 13:49:39 CEST Li Zetao wrote:
> Use the helper function devm_kmemdup() rather than duplicating its
> implementation, which helps to enhance code readability.
> 
> Signed-off-by: Li Zetao <lizetao1@huawei.com>
> ---
>  drivers/net/wireless/silabs/wfx/main.c | 7 +++----
>  1 file changed, 3 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/net/wireless/silabs/wfx/main.c b/drivers/net/wireless/silabs/wfx/main.c
> index 0b50f7058bbb..ede822d771aa 100644
> --- a/drivers/net/wireless/silabs/wfx/main.c
> +++ b/drivers/net/wireless/silabs/wfx/main.c
> @@ -293,13 +293,12 @@ struct wfx_dev *wfx_init_common(struct device *dev, const struct wfx_platform_da
>         hw->wiphy->max_scan_ie_len = IEEE80211_MAX_DATA_LEN;
>         hw->wiphy->n_iface_combinations = ARRAY_SIZE(wfx_iface_combinations);
>         hw->wiphy->iface_combinations = wfx_iface_combinations;
> -       hw->wiphy->bands[NL80211_BAND_2GHZ] = devm_kmalloc(dev, sizeof(wfx_band_2ghz), GFP_KERNEL);
> +       /* FIXME: also copy wfx_rates and wfx_2ghz_chantable */
> +       hw->wiphy->bands[NL80211_BAND_2GHZ] = devm_kmemdup(dev, &wfx_band_2ghz,
> +                                                          sizeof(wfx_band_2ghz), GFP_KERNEL);
>         if (!hw->wiphy->bands[NL80211_BAND_2GHZ])
>                 goto err;
> 
> -       /* FIXME: also copy wfx_rates and wfx_2ghz_chantable */
> -       memcpy(hw->wiphy->bands[NL80211_BAND_2GHZ], &wfx_band_2ghz, sizeof(wfx_band_2ghz));
> -
>         wdev = hw->priv;
>         wdev->hw = hw;
>         wdev->dev = dev;
> --
> 2.34.1
> 
> 

Make sense.

Reviewed-by: Jérôme Pouiller <jerome.pouiller@silabs.com>
Kalle Valo Aug. 23, 2023, 11:09 a.m. UTC | #2
Li Zetao <lizetao1@huawei.com> wrote:

> Use the helper function devm_kmemdup() rather than duplicating its
> implementation, which helps to enhance code readability.
> 
> Signed-off-by: Li Zetao <lizetao1@huawei.com>
> Reviewed-by: Jérôme Pouiller <jerome.pouiller@silabs.com>

Patch applied to wireless-next.git, thanks.

eaa8023e9bb3 wifi: wfx: Use devm_kmemdup to replace devm_kmalloc + memcpy
diff mbox series

Patch

diff --git a/drivers/net/wireless/silabs/wfx/main.c b/drivers/net/wireless/silabs/wfx/main.c
index 0b50f7058bbb..ede822d771aa 100644
--- a/drivers/net/wireless/silabs/wfx/main.c
+++ b/drivers/net/wireless/silabs/wfx/main.c
@@ -293,13 +293,12 @@  struct wfx_dev *wfx_init_common(struct device *dev, const struct wfx_platform_da
 	hw->wiphy->max_scan_ie_len = IEEE80211_MAX_DATA_LEN;
 	hw->wiphy->n_iface_combinations = ARRAY_SIZE(wfx_iface_combinations);
 	hw->wiphy->iface_combinations = wfx_iface_combinations;
-	hw->wiphy->bands[NL80211_BAND_2GHZ] = devm_kmalloc(dev, sizeof(wfx_band_2ghz), GFP_KERNEL);
+	/* FIXME: also copy wfx_rates and wfx_2ghz_chantable */
+	hw->wiphy->bands[NL80211_BAND_2GHZ] = devm_kmemdup(dev, &wfx_band_2ghz,
+							   sizeof(wfx_band_2ghz), GFP_KERNEL);
 	if (!hw->wiphy->bands[NL80211_BAND_2GHZ])
 		goto err;
 
-	/* FIXME: also copy wfx_rates and wfx_2ghz_chantable */
-	memcpy(hw->wiphy->bands[NL80211_BAND_2GHZ], &wfx_band_2ghz, sizeof(wfx_band_2ghz));
-
 	wdev = hw->priv;
 	wdev->hw = hw;
 	wdev->dev = dev;