mbox series

[net-next,00/11] net: hns3: some cleanups for -next

Message ID 20211203092059.24947-1-huangguangbin2@huawei.com (mailing list archive)
Headers show
Series net: hns3: some cleanups for -next | expand

Message

Guangbin Huang Dec. 3, 2021, 9:20 a.m. UTC
To improve code readability and simplicity, this series add some cleanup
patches for the HNS3 ethernet driver.

Guangbin Huang (3):
  net: hns3: refactor function hclge_set_vlan_filter_hw
  net: hns3: add print vport id for failed message of vlan
  net: hns3: modify one argument type of function
    hclge_ncl_config_data_print

Hao Chen (6):
  net: hns3: Align type of some variables with their print type
  net: hns3: align return value type of atomic_read() with its output
  net: hns3: add void before function which don't receive ret
  net: hns3: add comments for hclge_dbg_fill_content()
  net: hns3: remove rebundant line for hclge_dbg_dump_tm_pg()
  net: hns3: replace one tab with space in for statement

Jie Wang (1):
  net: hns3: fix hns3 driver header file not self-contained issue

Yufeng Mo (1):
  net: hns3: optimize function hclge_cfg_common_loopback()

 .../ethernet/hisilicon/hns3/hns3_debugfs.c    |   2 +-
 .../ethernet/hisilicon/hns3/hns3_debugfs.h    |   2 +
 .../net/ethernet/hisilicon/hns3/hns3_enet.h   |   3 +
 .../hisilicon/hns3/hns3pf/hclge_debugfs.c     |  13 +-
 .../hisilicon/hns3/hns3pf/hclge_devlink.c     |   2 +-
 .../hisilicon/hns3/hns3pf/hclge_main.c        | 121 +++++++++++-------
 .../hisilicon/hns3/hns3pf/hclge_mbx.c         |   2 +-
 .../hisilicon/hns3/hns3pf/hclge_mdio.h        |   4 +
 .../hisilicon/hns3/hns3pf/hclge_ptp.h         |   3 +
 .../ethernet/hisilicon/hns3/hns3pf/hclge_tm.h |   6 +
 .../hisilicon/hns3/hns3vf/hclgevf_devlink.c   |   2 +-
 11 files changed, 106 insertions(+), 54 deletions(-)

Comments

patchwork-bot+netdevbpf@kernel.org Dec. 3, 2021, 11:20 a.m. UTC | #1
Hello:

This series was applied to netdev/net-next.git (master)
by David S. Miller <davem@davemloft.net>:

On Fri, 3 Dec 2021 17:20:48 +0800 you wrote:
> To improve code readability and simplicity, this series add some cleanup
> patches for the HNS3 ethernet driver.
> 
> Guangbin Huang (3):
>   net: hns3: refactor function hclge_set_vlan_filter_hw
>   net: hns3: add print vport id for failed message of vlan
>   net: hns3: modify one argument type of function
>     hclge_ncl_config_data_print
> 
> [...]

Here is the summary with links:
  - [net-next,01/11] net: hns3: optimize function hclge_cfg_common_loopback()
    https://git.kernel.org/netdev/net-next/c/23e0316049af
  - [net-next,02/11] net: hns3: refactor function hclge_set_vlan_filter_hw
    https://git.kernel.org/netdev/net-next/c/e7a51bf590e3
  - [net-next,03/11] net: hns3: add print vport id for failed message of vlan
    https://git.kernel.org/netdev/net-next/c/114967adbc3d
  - [net-next,04/11] net: hns3: Align type of some variables with their print type
    https://git.kernel.org/netdev/net-next/c/0cc25c6a14ef
  - [net-next,05/11] net: hns3: modify one argument type of function hclge_ncl_config_data_print
    https://git.kernel.org/netdev/net-next/c/72dcdec10fad
  - [net-next,06/11] net: hns3: align return value type of atomic_read() with its output
    https://git.kernel.org/netdev/net-next/c/9fcadbaae8ea
  - [net-next,07/11] net: hns3: add void before function which don't receive ret
    https://git.kernel.org/netdev/net-next/c/5ac4f180bd07
  - [net-next,08/11] net: hns3: add comments for hclge_dbg_fill_content()
    https://git.kernel.org/netdev/net-next/c/4e599dddeea4
  - [net-next,09/11] net: hns3: remove rebundant line for hclge_dbg_dump_tm_pg()
    https://git.kernel.org/netdev/net-next/c/40975e749daa
  - [net-next,10/11] net: hns3: replace one tab with space in for statement
    https://git.kernel.org/netdev/net-next/c/7acf76b1cd01
  - [net-next,11/11] net: hns3: fix hns3 driver header file not self-contained issue
    https://git.kernel.org/netdev/net-next/c/184da9dc780e

You are awesome, thank you!