diff mbox series

[v3,20/25] s390x/sclp: Use a const variable to improve readability

Message ID 20190220010232.18731-21-philmd@redhat.com (mailing list archive)
State New, archived
Headers show
Series chardev: Convert qemu_chr_write() to take a size_t argument | expand

Commit Message

Philippe Mathieu-Daudé Feb. 20, 2019, 1:02 a.m. UTC
We will reuse this variable in the next patch.

Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com>
---
 hw/char/sclpconsole-lm.c | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

Comments

Cornelia Huck Feb. 20, 2019, 10:53 a.m. UTC | #1
On Wed, 20 Feb 2019 02:02:27 +0100
Philippe Mathieu-Daudé <philmd@redhat.com> wrote:

> We will reuse this variable in the next patch.
> 
> Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com>
> ---
>  hw/char/sclpconsole-lm.c | 7 ++++---
>  1 file changed, 4 insertions(+), 3 deletions(-)
> 
> diff --git a/hw/char/sclpconsole-lm.c b/hw/char/sclpconsole-lm.c
> index dbc91a1e5b..49543e2c83 100644
> --- a/hw/char/sclpconsole-lm.c
> +++ b/hw/char/sclpconsole-lm.c
> @@ -210,13 +210,14 @@ static int process_mdb(SCLPEvent *event, MDBO *mdbo)
>      int rc;
>      int len;
>      uint8_t buffer[SIZE_BUFFER];
> -
> -    len = be16_to_cpu(mdbo->length);
> -    len -= sizeof(mdbo->length) + sizeof(mdbo->type)
> +    const size_t hlen = sizeof(mdbo->length)
> +            + sizeof(mdbo->type)
>              + sizeof(mdbo->mto.line_type_flags)
>              + sizeof(mdbo->mto.alarm_control)
>              + sizeof(mdbo->mto._reserved);
>  
> +    len = be16_to_cpu(mdbo->length);
> +    len -= hlen;
>      assert(len <= SIZE_BUFFER);
>  
>      /* convert EBCDIC SCLP contents to ASCII console message */

I'd probably merge this with the next patch, though.

Reviewed-by: Cornelia Huck <cohuck@redhat.com>
Philippe Mathieu-Daudé March 8, 2019, 7:12 p.m. UTC | #2
On 2/20/19 11:53 AM, Cornelia Huck wrote:
> On Wed, 20 Feb 2019 02:02:27 +0100
> Philippe Mathieu-Daudé <philmd@redhat.com> wrote:
> 
>> We will reuse this variable in the next patch.
>>
>> Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com>
>> ---
>>  hw/char/sclpconsole-lm.c | 7 ++++---
>>  1 file changed, 4 insertions(+), 3 deletions(-)
>>
>> diff --git a/hw/char/sclpconsole-lm.c b/hw/char/sclpconsole-lm.c
>> index dbc91a1e5b..49543e2c83 100644
>> --- a/hw/char/sclpconsole-lm.c
>> +++ b/hw/char/sclpconsole-lm.c
>> @@ -210,13 +210,14 @@ static int process_mdb(SCLPEvent *event, MDBO *mdbo)
>>      int rc;
>>      int len;
>>      uint8_t buffer[SIZE_BUFFER];
>> -
>> -    len = be16_to_cpu(mdbo->length);
>> -    len -= sizeof(mdbo->length) + sizeof(mdbo->type)
>> +    const size_t hlen = sizeof(mdbo->length)
>> +            + sizeof(mdbo->type)
>>              + sizeof(mdbo->mto.line_type_flags)
>>              + sizeof(mdbo->mto.alarm_control)
>>              + sizeof(mdbo->mto._reserved);
>>  
>> +    len = be16_to_cpu(mdbo->length);
>> +    len -= hlen;
>>      assert(len <= SIZE_BUFFER);
>>  
>>      /* convert EBCDIC SCLP contents to ASCII console message */
> 
> I'd probably merge this with the next patch, though.

The context is easier to review in 2 different patches IMHO.

> Reviewed-by: Cornelia Huck <cohuck@redhat.com>
> 

Thanks!

Phil.
diff mbox series

Patch

diff --git a/hw/char/sclpconsole-lm.c b/hw/char/sclpconsole-lm.c
index dbc91a1e5b..49543e2c83 100644
--- a/hw/char/sclpconsole-lm.c
+++ b/hw/char/sclpconsole-lm.c
@@ -210,13 +210,14 @@  static int process_mdb(SCLPEvent *event, MDBO *mdbo)
     int rc;
     int len;
     uint8_t buffer[SIZE_BUFFER];
-
-    len = be16_to_cpu(mdbo->length);
-    len -= sizeof(mdbo->length) + sizeof(mdbo->type)
+    const size_t hlen = sizeof(mdbo->length)
+            + sizeof(mdbo->type)
             + sizeof(mdbo->mto.line_type_flags)
             + sizeof(mdbo->mto.alarm_control)
             + sizeof(mdbo->mto._reserved);
 
+    len = be16_to_cpu(mdbo->length);
+    len -= hlen;
     assert(len <= SIZE_BUFFER);
 
     /* convert EBCDIC SCLP contents to ASCII console message */