Message ID | 20210922061438.27645-14-imp@bsdimp.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | bsd-user: misc cleanup for aarch64 import | expand |
On 9/21/21 11:14 PM, Warner Losh wrote: > To avoid a name clash with FreeBSD's sigqueue data structure in > signalvar.h, rename sigqueue to qemu_sigqueue. This sturcture > is currently defined, but unused. > > Signed-off-by: Warner Losh<imp@bsdimp.com> > --- > bsd-user/qemu.h | 14 +++++++------- > 1 file changed, 7 insertions(+), 7 deletions(-) Reviewed-by: Richard Henderson <richard.henderson@linaro.org> r~
On 9/22/21 08:14, Warner Losh wrote: > To avoid a name clash with FreeBSD's sigqueue data structure in > signalvar.h, rename sigqueue to qemu_sigqueue. This sturcture > is currently defined, but unused. > > Signed-off-by: Warner Losh <imp@bsdimp.com> > --- > bsd-user/qemu.h | 14 +++++++------- > 1 file changed, 7 insertions(+), 7 deletions(-) Reviewed-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
diff --git a/bsd-user/qemu.h b/bsd-user/qemu.h index 3dde381d5d..5a2fd87e44 100644 --- a/bsd-user/qemu.h +++ b/bsd-user/qemu.h @@ -73,15 +73,15 @@ struct image_info { #define MAX_SIGQUEUE_SIZE 1024 -struct sigqueue { - struct sigqueue *next; +struct qemu_sigqueue { + struct qemu_sigqueue *next; + target_siginfo_t info; }; struct emulated_sigtable { int pending; /* true if signal is pending */ - struct sigqueue *first; - /* in order to always have memory for the first signal, we put it here */ - struct sigqueue info; + struct qemu_sigqueue *first; + struct qemu_sigqueue info; /* Put first signal info here */ }; /* @@ -95,8 +95,8 @@ typedef struct TaskState { struct image_info *info; struct emulated_sigtable sigtab[TARGET_NSIG]; - struct sigqueue sigqueue_table[MAX_SIGQUEUE_SIZE]; /* siginfo queue */ - struct sigqueue *first_free; /* first free siginfo queue entry */ + struct qemu_sigqueue sigqueue_table[MAX_SIGQUEUE_SIZE]; /* siginfo queue */ + struct qemu_sigqueue *first_free; /* first free siginfo queue entry */ int signal_pending; /* non zero if a signal may be pending */ uint8_t stack[];
To avoid a name clash with FreeBSD's sigqueue data structure in signalvar.h, rename sigqueue to qemu_sigqueue. This sturcture is currently defined, but unused. Signed-off-by: Warner Losh <imp@bsdimp.com> --- bsd-user/qemu.h | 14 +++++++------- 1 file changed, 7 insertions(+), 7 deletions(-)