mbox series

[v3,00/26] xfsprogs: refactor buffer function names

Message ID 158293297395.1549542.18143701542461010748.stgit@magnolia (mailing list archive)
Headers show
Series xfsprogs: refactor buffer function names | expand

Message

Darrick J. Wong Feb. 28, 2020, 11:36 p.m. UTC
Hi all,

This series cleans up several messes in the libxfs buffer handling code.
First, we get rid of the overloaded (and in some places hidden usages)
of LIBXFS_EXIT_ON_FAIL flag that is sprinkled throughout the buffer
callers.  Next, we rename the buffer get/read/put/write functions to
match their kernel counterparts, which enables us to remove a bunch of
ugly #defines.  Then, we replace the open-coded uncached buffer logic in
the callers with the same uncached buffer API as the kernel has.
Finally, we move as many callers as we feasibly can to use the
xfs_buf_(get|read) interfaces so that we don't have multiple entry
points to the same functionality.

For v2, move the "exit on io error" functionality directly into the
callers.  v3 added a set_buf_priority demacroing patch at the end.

If you're going to start using this mess, you probably ought to just
pull from my git trees, which are linked below.

This is an extraordinary way to destroy everything.  Enjoy!
Comments and questions are, as always, welcome.

--D

xfsprogs git tree:
https://git.kernel.org/cgit/linux/kernel/git/djwong/xfsprogs-dev.git/log/?h=libxfs-refactor-buffer-funcs